getting grub to run splasy instead of bootsplash

i am trying to replace bootsplash with splashy
i have uninstalled bootsplash, and i have splashy installed
when i type /usr/sbin/splashy boot into a terminal window i get the splashy boot screen, so i know it is installed ok, but when i boot i get only text

i have tried adding /usr/sbin/splashy boot to /etc/init.d using boot boot.local and as a rc3.d script.

these all show the screen, but there is lots of boot messages before it runs, meaning that i get loads of tet followed by a few seconds of splashy

i assume the change needs to be in the grub settings file /boot/grub/menu.lst

the entry in /boot/grub/menu.lst for the option i use is

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 -
root (hd1,1)
kernel /boot/vmlinuz- root=/dev/disk/by-id/usb-Maxtor_OneTouch_III_2CASDMEP-0:0-part2 resume=/dev/disk/by-id/usb-Maxtor_OneTouch_III_2CASDMEP-0:0-part1 splash=silent showopts vga=0x317
initrd /boot/initrd-

what do i need to add/delete/change for grub to loads splashy before any boot messages or text is displayed?

any help would be greatly appreciated


mkdir -p /tmp/initrd
cd /tmp/initrd
cat /boot/initrd.img | gzip -d | cpio -i

i have traced the problem to the inital ramdisk image’s init file not starting splashy

i know how to make a new initrd using mkinitrd, but this allways leaves splashy out

i have tried viewing the mkinitrd script and found the only reference to splash says

general configurable parameters


do i need to change this? if so what file needs to be changed to get the mkinitrd script to change this parameter

Mmm wonder what your doing afaik and google seems to agree Suse has used splashy for a while now.

Note 11.1 standard I’ve looked no further.

Unless you have an antique version I doubt you needed to install splashy but configure it.

Nope, Suse 11.1 installs splashy but still uses bootsplash, you can find it out easily by looking at your boot.msg. mkinitrd seems to ignore splashy scripts as well in favour of bootsplash.

did you ever manage to replace bootsplash with splashy? i’m trying to do the same thing right now, but don’t know how. thanks.