Getting back file permisssions

I recently tried CentOS & used my existing Home directory. Since then file permissions have changed. Now the owner of the folders are “500 - user #500”. No matter what cant change back to my username, its not selectable.

Please reply.

have you tried

su -c "chown -R yourname:users  /home/yourname"

Of course, make a backup first

And apart from swerdna’a advice, you do not seem to understand what happened. The permission of those files did not change at all. After all you simply mounted that existing file system with all that is in there and nothing in the contents is changed.

What changed is that you now use a different user. The userid on your CenOS system was 500. When you create a new user on openSUSE, they start by default with 1000. And I gues this user you are talking about now has userid 1000. This userid is regardless of the username you have geiven to it (and that most probably was the same on both systems). The usernames (and the same is for group names) are only easy to remember names that in reality are numbers. And the numbers count.

Thus your user 1000 is not the owner of all the files in /home under user <username>, because they are owned by user 500. Which has no name attached in your openSUSE, thus the number is shown in all sorts of lists you look at.

I also guess that by “No matter what cant change back to my username, its not selectable.”, you mean that you tried to change as the user. Of course you can not do this as the user. User A can not change things that are owned by userB. You must be root. And swerdna gave you the command to do this.

Done !!! Thanks:|