Getting a Grub2 command line on boot instead of the normal OS option menu

https://i.imgur.com/qzHgCbK.jpg

I did a fresh install (not update), using the same partition setup as I had with previous Leap versions, reformatting all except home and file storage drives.

On turning on the computer, I get the above command line.

However, if I put the Leap 15.2 Net Installer CD I used for installation in the drive, and use “boot from hard disk” option on that, it goes to the normal OS option menu. (I have no other OSes on this computer.)

As a SUSE/OpenSUSE user since 7.1, I’ve never seen this happen in previous versions.

I’ve tried changing almost every option in the YaST Boot Loader in a hope-for-the-best manner but nothing changed.

***I’m at a loss as to what to look for, or even what info is needed to help figure this out. ***

(I did not try Leap 15.1 due to laziness, kept 15.0 until 15.2 was released, so it may well be an issue that appeared with 15.1 and I didn’t see it.)

Until I can fix it, using boot from hard disk on the installation CD will keep me going, especially since I never shutdown or reboot this comp unless absolutely necessary, but would prefer a way to solve this.

Maybe you changed the boot order in the BIOS to be able to boot the install media and didn’t change back thereafter?
Is this a legacy/MBR booting or an UEFI booting system?

I’m not sure what went wrong. But your screen image is for grub-2.02, while Leap 15.2 is using grub-2.04. So somehow you are using an older grub installed for a different system.

Check how your system is booting. As OrsoBruno suggested, it is possible that you installed for UEFI booting but your BIOS is currently configured for legacy booting.

Can you boot the install media and select “Boot from hard drive” – Does that get you into your system?

I honestly couldn’t say what exactly I did, but something I randomly gave a try at made it work right. After multiple attempts at quite a few things. Maybe it was a combo of things.

But at any rate, it’s fixed now. Really wish I knew what I did that fixed it, but I’ll be happy with it working. :wink:

Being an older hard drive, I had a separate-from-root boot/grub partition (I think) that I may have forgotten to format from 15.0 while a new one installed in /boot, and maybe my tweaking pointed it to the correct grub. (Lot of guessing here now that it’s done.)

And yeah, the install media boot from hard drive was how I was getting into the system before it worked.

Whatever it was, it was most likely a human error on my part, not the install.

Yes, that seems likely.

I’m glad things are back to working.

Testing openSUSE since 1995 and using it since 1996 (v 4.3) I have never seen a similar problem as yours on my machines and many others. Installing Leap 15.2 several hours before official release was an extremely smooth experience: openSUSE Leap 15.2 | Karl Mistelberger

I always reload default settings and turn off Compatibility Support Module. With secure boot turned off grub uses a single file /boot/efi/EFI/leap-15.2/grubx64.efi. There is nothing left to go wrong. Your issue could be a glitch or be related to shaky hardware or firmware. Vendors recommend to reset the board to factory defaults when encountering problems.