Get rid of rfkill permanently?

I’ve installed OpenSuse Leap 15.4 on a new HP laptop. Now every time I open the lid, wifi connection goes down (blocked by rfkill). How do I get rid of this behaviour, once and for all?

If you want rfkill to stop working you can make it not executable

sudo chmod 000 /usr/sbin/rfkill

to turn it back on

sudo chmod 755 /usr/sbin/rfkill

Me - I use the power module to make the laptop screen closed do nothing. It is in the MATE desktop. It is System > Hardware > Power Management in MATE desktop.

MATE looks and feels like Windows XP or Vista did. I hate the Windows 10/11 feel of gnome.

I have no idea where it is in gnome or kde.

1 Like

In KDE Plasma:
systemsettings → hardware → power management → wifi

1 Like

Yes, disabling hibernation or whatever happens when I close the lid seems the correct way to fix the unwanted behaviour. Will look into the power management. I’m not using integrated graphics environments but I think I can fire up a gnome desktop to get to the settings, if I can’t find a way to do it in the CL. Thanks for your reply!