Get no login screen

I upgraded 42.2 to 42.3. I can log in remotely, but the console never shows a login screen. I get just a large grey arrow that responds to the mouse.
in the upgrade, at the end, I got an error message about the boot disk being listed twice in Grub.
on boot, I see
Bert: can’t request IOMEM region
How do I fix this?
Thanks for the help,
Jim

You’ll have to describe what method or guide you used for your upgrade.
In particular, did you follow one of the methods described in the SDB System upgrade?

https://en.opensuse.org/SDB:System_upgrade

Also, if you can post a screenshot, it might be helpful.
For now, your description sounds to me perhaps that you’re in an Openbox environment.

TSU

I put in the DVD, rebooted, and selected upgrade. The way I always do.

I have a Dell D11S with a Xeon and 32 GB memory

In the system log, I get

2017-07-30T15:32:02.755381-04:00 jardell systemd[2637]: Reached target Timers.2017-07-30T15:32:02.755578-04:00 jardell systemd[2637]: Reached target Paths.
2017-07-30T15:32:02.755718-04:00 jardell systemd[2637]: Reached target Sockets.
2017-07-30T15:32:02.755821-04:00 jardell systemd[2637]: Reached target Basic System.
2017-07-30T15:32:02.755917-04:00 jardell systemd[2637]: Reached target Default.
2017-07-30T15:32:02.756044-04:00 jardell systemd[2637]: Startup finished in 13ms.
2017-07-30T15:32:02.756151-04:00 jardell systemd[1]: Started User Manager for UID 478.
2017-07-30T15:32:02.757549-04:00 jardell sddm[2516]: Greeter session started successfully
2017-07-30T15:32:02.791476-04:00 jardell sddm-greeter[2647]: High-DPI autoscaling Enabled2017-07-30T15:32:02.846147-04:00 jardell sddm-greeter[2647]: Reading from "/usr/share/xsessions/gnome-classic.desktop"
2017-07-30T15:32:02.846365-04:00 jardell sddm-greeter[2647]: Reading from "/usr/share/xsessions/gnome.desktop"
2017-07-30T15:32:02.846554-04:00 jardell sddm-greeter[2647]: Reading from "/usr/share/xsessions/icewm-session.desktop"
2017-07-30T15:32:02.846889-04:00 jardell sddm-greeter[2647]: Reading from "/usr/share/xsessions/icewm.desktop"
2017-07-30T15:32:02.846981-04:00 jardell sddm-greeter[2647]: Reading from "/usr/share/xsessions/kde-plasma.desktop"
2017-07-30T15:32:02.847070-04:00 jardell sddm-greeter[2647]: Reading from "/usr/share/xsessions/plasma5.desktop"
2017-07-30T15:32:02.847167-04:00 jardell sddm-greeter[2647]: Reading from "/usr/share/xsessions/sle-classic.desktop"
2017-07-30T15:32:02.847292-04:00 jardell sddm-greeter[2647]: Reading from "/usr/share/xsessions/xsession.desktop"
2017-07-30T15:32:02.920929-04:00 jardell systemd[1]: Started Postfix Mail Transport Agent.
2017-07-30T15:32:02.921513-04:00 jardell systemd[1]: Started Command Scheduler.
2017-07-30T15:32:02.921663-04:00 jardell systemd[1]: Reached target Multi-User System.
2017-07-30T15:32:02.921759-04:00 jardell systemd[1]: Reached target Graphical Interface.
2017-07-30T15:32:02.922026-04:00 jardell systemd[1]: Starting Update UTMP about System Runlevel Changes...
2017-07-30T15:32:02.922732-04:00 jardell cron[2706]: (CRON) INFO (RANDOM_DELAY will be scaled with factor 56% if used.)
2017-07-30T15:32:02.923053-04:00 jardell cron[2706]: (CRON) INFO (running with inotify support)
2017-07-30T15:32:02.925808-04:00 jardell systemd[1]: Started Update UTMP about System Runlevel Changes.
2017-07-30T15:32:02.925994-04:00 jardell systemd[1]: Startup finished in 1.225s (kernel) + 1.536s (initrd) + 12.838s (userspace) = 15.599s.
2017-07-30T15:32:02.928822-04:00 jardell sddm-greeter[2647]: Connected to the daemon.
2017-07-30T15:32:02.928979-04:00 jardell sddm[2516]: Message received from greeter: Connect
2017-07-30T15:32:02.931125-04:00 jardell sddm-greeter[2647]: Loading file:///usr/share/sddm/themes/breeze-openSUSE/Main.qml...
2017-07-30T15:32:03.009575-04:00 jardell sddm-greeter[2647]: QObject::installEventFilter(): Cannot filter events for objects in a different thread.
2017-07-30T15:32:03.423515-04:00 jardell sddm-greeter[2647]: QObject::installEventFilter(): Cannot filter events for objects in a different thread.
2017-07-30T15:32:03.482224-04:00 jardell dbus[1091]: [system] Activating via systemd: service name='org.freedesktop.UDisks2' unit='udisks2.service'
2017-07-30T15:32:03.510017-04:00 jardell systemd[1]: Starting Disk Manager...
2017-07-30T15:32:03.513399-04:00 jardell udisksd[2726]: udisks daemon version 2.1.6 starting
2017-07-30T15:32:03.543277-04:00 jardell dbus[1091]: [system] Successfully activated service 'org.freedesktop.UDisks2'
2017-07-30T15:32:03.543483-04:00 jardell udisksd[2726]: Acquired the name org.freedesktop.UDisks2 on the system message bus
2017-07-30T15:32:03.543638-04:00 jardell systemd[1]: Started Disk Manager.
2017-07-30T15:32:03.544641-04:00 jardell dbus[1091]: [system] Activating via systemd: service name='org.freedesktop.UPower' unit='upower.service'
2017-07-30T15:32:03.546714-04:00 jardell systemd[1]: Starting Daemon for power management...
2017-07-30T15:32:03.680003-04:00 jardell dbus[1091]: [system] Successfully activated service 'org.freedesktop.UPower'
2017-07-30T15:32:03.680256-04:00 jardell systemd[1]: Started Daemon for power management.
2017-07-30T15:32:04.096149-04:00 jardell sddm-greeter[2647]: Adding view for "default" QRect(0,0 640x480)
2017-07-30T15:32:04.099466-04:00 jardell sddm-greeter[2647]: QDBusConnection: name 'org.freedesktop.UDisks2' had owner '' but we thought it was ':1.26'
2017-07-30T15:32:04.101872-04:00 jardell sddm-greeter[2647]: Message received from daemon: Capabilities
2017-07-30T15:32:04.102097-04:00 jardell sddm-greeter[2647]: Message received from daemon: HostName
2017-07-30T15:32:04.106123-04:00 jardell sddm-greeter[2647]: QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
2017-07-30T15:32:04.106361-04:00 jardell sddm-greeter[2647]: Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 1, profile  0) 
2017-07-30T15:32:04.197660-04:00 jardell sddm-helper[2633]: [PAM] Closing session
2017-07-30T15:32:04.206334-04:00 jardell sddm-helper[2633]: [PAM] Ended.

It could also be due to the Graphics driver. In Xorg.0.log, I get

    14.443] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the    14.443] (EE) NVIDIA:     system's kernel log for additional error messages and
    14.443] (EE) NVIDIA:     consult the NVIDIA README for details.

I followed https://en.opensuse.org/SDB:NVIDIA_drivers to install the latest drivers, and did NOT approve the experimental 3D ones. I have a Quadro K1200 GM107GL video card.

I fixed it!
The update did not update the NVidia drivers. Nor did zypper update, even though the Nvidia repositories are there. I fixed it by manually selecting update in the YAST Software Management screen under Nvidia.

Generally proprietary drivers are not upgraded since they are proprietary and openSUSE is open only. Note the name.