get_iplayer problem

I am trying to download a programme from the BBC iplayer, using get_iplayer version 2.48

I get an error message saying that it needs rtmpdump >= 1.5, or flvstreamer. I have rtmpdump version 1.4 installed, but can’t find either rtmpdump>=1.5 or flvstreamer for opensuse (11.1).

Can anyone help, please?

Did not rtmpdump run into legal problems and have to be removed from source forge, its hosting site (as Adobe went after the developer(s) of rtmpdump claiming unlawful infringement) ? … and hence since then Packman packagers have not packaged any newer version?
Adobe claims rtmpdump ‘can be used’ to infringe – Chilling Effects Clearinghouse

You can download it from here. I packaged it and there is an install guide.

You will need to un-install what you have first

Thank you both for your help and advice.

OldCPU: Ah! Now I understand the flvstreamer/rtmpdump fork.

caf4926: I have been unable to get the link you gave to work.

Try this:

Once you have it installed the easiest way of using it is

Set the scrolling in your terminal to at least 2000
type: get_iplayer
And it will bring down all the tv feeds, each program has a number eg: 50
You then have to type get_iplayer again as follows:

I find the best results come from this

get_iplayer --get 50 --vmode=flashvhigh

Or you can add a few at a time

get_iplayer --get 50 60 75 99 --vmode=flashvhigh

It downloads a flash video but flvstreamer will use ffmpeg to encode to mp4. All done automatically and saves to your home directory.

For HD programs you can do

get_iplayer --get 50 --vmode=flashhd

Very many thanks, caf4926.

I have tried the Packman version successfully, but I needed the upgrade to get the higher quality video (and to try out the PVR application). You have solved the problem!

Thanks again

You are welcome;)

I’d be pleased to get this, but the download appears to be empty. “Save link as” downloads but with size 0b

May I ask for your help, please?

See if you can get it from here - Windows Live

Got it, thank you