Get_Iplayer 1 click install fails with repo sites. Is there a fix please?

I have been trying to use the 1 click install from the community packages, I believe Malcolm’s name was mentioned.
Unfortunately the installation failed and I seek guidance please.
I have in earlier years used the manual installation method but had hoped to save some time here.
I note the version in the Community package has now been superseded by version 3.28. I rather hoped I could install v3.27 and then upgraded it.
All help/guidance appreciated.

Yes, I haven’t updated in some time…

Install direct, don’t use 1-click…

zypper in

Just updated it, not many changes… the 3.27 version may still be there, if not, use 3.28.

zypper in

Hi Malcolm,
Many thanks. Will use your command but seek a bit of help with dependencies please.
I am being lazy I know but am having trouble with the Perl modules and Leap15.3
Do you have a list of these as they appear in Yast software so I can install. Seems like every time I try a new installation the modules are shown differently.

Further to this, once again I find no support for Leap 15.3, this time for perl-JSON-PP.

At this rate I shall have to revert to TW and put up with the nagging as at least most of what I want is supported.

How do I solve this please?

You need to add the Perl Development repo…

zypper ar -f -g -n "Perl Development" devel:lnguages:perl

Are you sure you need it? According to documentation, it is used as fallback when [noparse]JSON:XS[/noparse] is not available, and perl-JSON-XS is in 15.3.

Good catch, let me update the requires.

Updated build;

zypper in

Many thanks to Malcolm and arvidjaar for the brilliant help and sorry to have created so much work.

I now have GiP installed again after an absence of over 4 years. Now have to remember how I used it!

I don’t need it now but I used to use the pvr and cron to download some regular favourites. Does the pvr still work? Will ask again when I have the basic working again.

Thanks again,

The pvr part is split out;

zypper in

Hi Malcolm,
This morning when I tried to install GiP I received a warning this:-

warning: /var/cache/zypper/RPMS/get_iplayer-3.28-lp153.2.1.noarch.rpm: Header V3 RSA/SHA256 Signature, key I
D 479de3c9: NOKEY   

and for pvr:-

get_iplayer-pvr-3.28-lp153.2.1.noarch (Plain RPM files cache): Signature verification failed 4-Signatures public key is not available

I took a chance and ignored it but please advise where I went wrong.

No idea why my quotes were munged but the question is valid.

Also I may have used an old command for pvr but am getting the following:-

INFO: Downloading radio: 'Composer of the Week: Edward Elgar (1857-1934) - 02. A Catholic in an Anglican Cou
ntry (m00140rh) [original]' 
INFO: Downloaded: 147.62 MB (00:58:44) @ 35.79 Mb/s (hafhigh1/bi) [audio]        
INFO: Converting to M4A 
INFO: Command exit code 1 (raw code = 256) 
ERROR: Conversion failed - retaining audio file: /home/alastair/GiP_Recordings/Composer_of_the_Week_Edward_E
INFO: Skipping all versions of this programme

I have ffmpeg installed. In the wrong place perhaps? Will check but am updating as I go in case there is a problem above.

I have now installed GiP and PVR on another machine and I did not receive any NOKEY warning.
This suggest to me that I have an error in my installation on the machine which gives the error.
Should I post a new thread on this or is it easily fixed.

No, the nokey warning is expected. Maybe the other machine has used my repository and added the key.

I checked the repos on the machine which installed without any warning but there is no sign of your repo so in theory I should have had the warning. Strange, I shall check the other machine.
Since I ignored the warning I have the installations in place but cannot work out why the decoding is not working.
This results in two files for each programme (radio 3 stuff).
I have Atomicparsley in place and ffmpeg. Both are in my /usr/bin directory.
Will post on GiP list.

The ffmpeg from packman?

It’s also been updated to version 3.29…

zypper in
zypper in

Hi Malcolm,
Will update now but all running well so far thanks. If I run these now will they just overwrite the old with the new?

The background to the ffmpeg in my system was that when I did updates a while ago I recall seeing a note somewhere to the effect that the proprietary packages needed for multimedia were now open so I didn’t do the switch. Clearly I misunderstood and have now done the usual switch to Packman on all devices.

Many thanks once more.

Yes, but read the changes in the changelog or at