Get brand new windows to boot

So I got a new job and the company provided a brand new laptop. The nature of the work allowed me to choose the OS I’d be using on this laptop, and naturally I picked my favourite OS, OpenSUSE with Gnome.
Anyway, installing opensuse was the first thing I did with the laptop, followed by a lengthy session of configuring software, which I’ll be using daily for work.

The problem is that now I was trying to get Bubblebee to work so I can play games on my free time, and I’m about to give up and try to use windows for my gaming instead.

So I thought to myself, just reboot, pick the windows option on grub, follow the steps that show up when you first boot windows and it’s done.
Well, grub doesn’t have that option and I’m seeking help with using the windows that came preinstalled without messing up my opensuse.

When I installed opensuse, I used about 500Gb, leaving the first 500Gb for windows, in hopes that one day I’d be able to use it if I needed it.

Thank you in advanced for your time!

Couple of things

  1. did you install openSUSE in the same boot mode as Windows? Most likely EFI. If not then you can not chain between OS since they boot different

  2. did you turn off fast boot in Windows? That leaves the Windows partition in a dirty condition and Linux may not see it

  3. Can you use the EFI boot menu to boot to Windows?

Thank you for your help,

I didn’t do anything to windows yet, but before installing opensuse I did go to the BIOS and change it from EFI to CSM (or whatever it’s called).
As I was installing opensuse, during the partitioning bit, the installer warned me about needing a boot partition, and so I added one of those with a few megas at the end of the drive, but I really don’t know where grub was installed. Maybe MBR, maybe that new partition.

Here’s my fdisk -l

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 4C5D538E-A9B6-11E5-8953-C3F04C28B9E4

Device          Start        End    Sectors   Size Type
/dev/sda1        2048     534527     532480   260M EFI System
/dev/sda2      534528     567295      32768    16M Microsoft reserved
/dev/sda3      567296  681723295  681156000 324.8G Microsoft basic data
/dev/sda4  1926901760 1930178559    3276800   1.6G Windows recovery environment
/dev/sda5  1930178560 1953523711   23345152  11.1G Windows recovery environment
/dev/sda6   681723904  685926399    4202496     2G Microsoft basic data
/dev/sda7   685926400  874674175  188747776    90G Microsoft basic data
/dev/sda8   874674176 1925341183 1050667008   501G Microsoft basic data
/dev/sda9  1925341184 1926901759    1560576   762M BIOS boot

Partition table entries are not in disk order.

I believe I only created sda7, sda8 and sda9 during the opensuse installation.

Also, how I think the EFI boot menu only has the option to ‘Boot from harddrive’ and not a specific OS, but i’ll check anyway
EDIT: The boot menu only has a boot from harddrive which boots to grub as normal

Ok changing the BIOS is the problem that is legacy mode and not needed and you CAN NOT cross boot if one OS is EFI and the other legacy. Both must be installed using the same boot method.

So, can I change the bios to efi and just reinstall grub? Or do I have to reinstall one of the OS?

reinstalling grub in EFI mode might work, never really tried it.

First switch to EFI mode. note Windows may then appear in the efi boot menu

The requirements for EFI and legacy are different. In EFI boot there is NO MBR. EFI uses the special FAT formatted EFI boot partition for all OS’s installed. it is mounted as /boot/efi in openSUSE so there must be that partition mounted. EFI boot uses grub2-efi not grub2 . So you must first set the efiboot partition to mount a FAT not formatted on /boot/efi. ( sda1 should be it). Use Yast partition manager. Then in yast boot loader change things to grub2-efi and set scan for foreign OS on. Also set secure boot chackbox. Think that might work

Personally I’d just reinstall doing it right and manually selecting the partitions

In Windows be sure that fast boot is off otherwise you won’t be able to mount a Windows partition.

Thank you for the help.
I’ve done a quick google search and came up with an article for Debian, describing how to switch from legacy to EFI. However, it’s clear that I should read more on the subject before trying anything, since this is my work computer and must be operational during the week.

Maybe I’ll open a dedicated thread during the week if I can’t find a way to do it. For now I think I’ll try installing the nvidia optimus drivers one more time.

Thanks again for your help

Safest way is to simply reinstall and be sure you manually select and set the partitions. Boot the installer in EFI mode

The absolute easiest way to to remove the Linux partitions and let the installer use the free space, otherwise you must show the installer where you want to install things since there is no place free for the installer work and it is not any good reading your mind.