get audacity to record from website

i tried every input, ou put device configuaration in audacity to try to caapture audio but it wont. i have alsa in the audio host. i have Realtek ALC892 8-Channel High Definition Audio CODEC

output device options
-default
-spdif
-iec958
-hda intel pch alc877-vd digital(hw:0.1)

input device options
-default
-sysdefault
-hda intel pch acl887-vd analog (hw: 0.2) line 1
-hda intel pch acl887-vd analog (hw: 0.2)front mic 1
-hda intel pch acl887-vd analog (hw: 0.2)rear mic 1
-hda intel pch acl887-vd analog (hw: 0.2)line 0
-hda intel pch acl887-vd analog (hw: 0.2)front mic 0
-hda intel pch acl887-vd analog (hw: 0.2)rear mic 0
-hda intel pch acl887-vd analog (hw: 0.0)

configure audacity to record from a website or off my desktop?

I’ve never tried this myself. I do NOT use audacity.

Will/does audacity work with pulse audio ?

If so, you should be able to re-direct any audio input that arrives in your PC to the audacity audio capture. The program ‘pavucontrol’ may help. Its possible you may need to edit a configuration file (such as the /etc/pulse/default.pa ).

Here is an old thread where I documented the results of my playing with pulse audio: Looking (maybe) for audio mixer for use with Pulse Audio

how do i check if i have pulse? i have alsa plugins pulse and alsa plugins pulse 32 bit… i have a 64 bit computer.

when i click on kmix it wont open?

found that pulseaudio is checked in yast

then shouldnt i have the option to pick pulseaudio in audacity, i only have the option to pick alsa in audacity

I am using 12.1 64 bit version and had no problem using audacity to record the sound from my web browser. I don’t have pulse installed and my audacity settings going across (L-R) are:-

alsa

sysdefault

sysdefault: stereo

2 (Stereo) Input Channels

i only have default in both input and output devices. i dont have sysdefault nor sysdefault: stereo.

with both my default on i still cant record audio from a website or off of youtube. how is your system setup do you have an audio card my audio is on my motherboard?

i don’t know exactly what i did but i put both input & output devices on default then changed the settings around several time in pulseaudio volume control serendipitously til audacity worked. not sure even if it was that

Well done on getting things sorted.

I have a Realtek onboard sound chip like you - so I suppose the difference in our system settings must have been down to you haveing pulse and me having removed it.

i dont exactly know what pulse audio is but is there a reason you uninstalled yours?

thanks

I have just got into the habit of uninstalling pulse from a few versions of opensuse ago when it was a bit flaky.

One tip I would offer is for you to write down your audacity settings - now that you have got things working in case you ever need to re-install your system.