"Generic Monitor" - is this normal?

I had to revert to a version of xorg.conf that was created right after install when I installed an ATI driver that did not work.

I can now boot back into KDE (I also removed the driver), but I now appear to be using “Generic Monitor” according to hwinfo. Is this normal?

Also, whenever I go to KDE Settings > Desktop the applet segfaults immediately. I used to be able to do this before I installed the ATI driver. Can this be fixed? I’m using KDE 4.4.x from the openSUSE repositories.

hwinfo on my monitor:

75: None 00.0: 10000 Monitor
[Created at fb.71]
Hardware Class: monitor
Model: “Generic Monitor”
Vendor: “Generic”
Device: “Monitor”
Resolution: 1600x900@77Hz
Driver Info #0:
Max. Resolution: 1600x900
Vert. Sync Range: 50-90 Hz
Hor. Sync Range: 31-72 kHz
Config Status: cfg=new, avail=yes, need=no, active=unknown

hwinfo on my video card:

31: PCI 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
Parent ID: vSkL.CSC3Mknf3r5
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “ATI RADEON Graphics Processor (M93 9555)”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x9555 “ATI RADEON Graphics Processor (M93 9555)”
SubVendor: pci 0x103c “Hewlett-Packard Company”
SubDevice: pci 0x1471
Driver: “fglrx_pci”
Driver Modules: “fglrx”
Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
I/O Ports: 0x4000-0x4fff (rw)
Memory Range: 0xd4400000-0xd440ffff (rw,non-prefetchable)
Memory Range: 0xd4420000-0xd443ffff (ro,non-prefetchable,disabled)
IRQ: 16 (232 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00001002d00009555sv0000103Csd00001471bc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: fglrx
Driver Info #1:
XFree86 v4 Server Module: fglrx
3D Support: yes
Extensions: dri
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #17 (PCI bridge)

Smolt identifies my graphic card as “ATI Mobility Radeon HD 4500 Series”. I modified the bootloader to start openSUSE with a 1600x900 resolution because otherwise I couldn’t set my resolution to 1600x900 in KDE. You see, KDE no longer lists any resolutions other than the one I’m using at that time, which is weird because I had more resolutions to choose from before attempting to install the ATI driver.

How do I fix this issue? The ATI driver I tried was suggested by the wiki, but as I said that messed up the X server.

Your hwinfo results show that the fglrx (proprietary) driver is still in use. Can you tell us how you installed it (hard way or easy way)? Did you use ‘aticonfig --initial’ to configure it after installing the driver?

KDE no longer lists any resolutions other than the one I’m using at that time, which is weird because I had more resolutions to choose from before attempting to install the ATI driver.

I’m not sure that the KDE System Settings > Display Settings utility works so well with propritary drivers (depends on their xrandr compliance). However, the proprietary ATI driver comes with its own config tool called ‘amdcccle’. You could try that for dynamic adjustment.

I did the one-click install for “Install ATi driver for HD 2000-series and newer”, then rebooted. When the X server started, I always got a black screen. tty1-tty6 didn’t work either. So then I restored post-install xorg.conf to make X boot again.

I was mistaken. I had only uninstalled xorg-x11-driver-video-radeonhd. I did a search for fglrx and it turns out that ati-fglrxG02-kmp-desktop is still installed on my PC. Should I reinstall the package? This will probably result in me not being able to boot into X again, so what should I do then?

You’ll obviously need to reinstall the radeonhd package, if you’re going to use this driver. If you want to revert back to the radeon driver, remove both packages. This should be enough to get a basic desktop back. (Assuming you haven’t blacklisted the radeon driver as well).

Here’s a recent thread concerning a user who needed to reinstate the open source radeon driver:

after clean install opensuse 11.3, cannot startx due to “No screens found”

BTW, at worst case you can get a basic desktop via failsafe boot.

I uninstalled both packages, deleted xorg.conf and all symptoms I described are gone. Thanks!