Generic Laptop Install Troubles - No Wireless!!!

Hello OpenSUSE People,

I’ve recently installed OpenSUSE 11.0 on an older generic laptop, which is the first OpenSUSE install I’ve done. The model number on this laptop is 755II8 and the name on the top is infoclick. Their website, is a French Canadian website, and I have been unable to find any information about this laptop on their website, though that could be because of the language barrier.

Anyhow, most things worked right away, which is great, but some very important things did not work, and I’ve so far failed to get those things working properly, most notable, the wireless Internet, but also some proprietary video drivers.

The system came with Windows, and I should have grabbed a copy of the wireless driver before scrubbing it off of the drive, but I didn’t, and now I can’t figure out which driver to use for this computer.

Now, because the wireless didn’t come up, I tried plugging in my USB D-link wireless adapter, which has always worked for me, but which didn’t work this time. When I plug it in, the computer detects it, but the light doesn’t come on, and it doesn’t detect any connections, which it should.

That’s the major problem. I really need the wireless to work. Now for the less major problem, which is video codecs. I went to the OpenSUSE website and tried to install the drivers by using the utility that I found there, but it had dependency issues, so I instead tried searching for the necessary packages and installing what I could. Again, I had some dependence issues, and now, I’ve got most video playing (I use it for watching world news programs on miro), but some streams just cause miro to close. I’m thinking that the utility is just slightly out of date, and if it is, could someone please update it. If not, what gives?

Back to the wireless issue. I’ve posted two copies of my dmesg. One from before plugging in my USB Wireless, and another one from after. Also, I’ve attached the results of ifconfig. I would be very very thankful if someone could help me work this out. The internal wireless is preferred, but having the USB D-link working would also be ok. → my dmesg from before I plugging in my usb D-link. → my dmesg from after I plugged in my usb D-link. Notice lines 702 and 703…

#702 usbcore: registered new interface driver rt73usb
#703 phy0 -> rt2x00lib_request_firmware: Error - Failed to request Firmware. → my ifconfig

If you need anything more from me, don’t hesitate to ask, but please include newbie details, such as the full path to any command you want me to run.

Thanks in advance for all the great and wonderful help that I know is coming. You guys are great, and I think all software should be open.



imacimen wrote:
> #702 usbcore: registered new interface driver rt73usb
> #703 phy0 -> rt2x00lib_request_firmware: Error - Failed to request
> Firmware.

As this message clearly states, you need firmware for the device.

You will get more attention for wireless problems if you go to the wireless
forum. When you get there, please read the stickies at the start of the forum to
learn how to report data needed to help you.