General question: How to deal with WAYLAND spec. errors?

Hi all,

I’m using Wayland since 15.3, now 15.4 because I’ve had several pain in the neck graphic card (Intel built-in) incompatibilities, all of them gone with Wayland. Esp. no “sudden death”/freezes anymore with OpenGL…

On the other side, unfortunately, several apps doesn’t really work (already?) with Wayland. E.g. most of the VNC etc remote stuff IMHO doesn’t work very well. But fine, maybe in future…

I now found, that a very useful small app, written AFAIK in JAVA, OSS, has very limited functionality when using it with Wayland. It’s this app and it can be used for registered Austrians, non-Austrians or registered legal entities to sign EU-law compliant PDF docs, so as said very useful for me.
Signing itself good luck still possible, but any drag&drop or visual positioning operations don’t work with Wayland. Contacted the developer already, but he/they have no real experience with Wayland.

Do we have any docs/hints for this?


This is far too vague and generic question. The only possible answer is - you deal with these errors like with any other errors. You troubleshoot them, you find out conditions to reproduce them and you report them to developers. In the meantime you use some workarounds if available.

There is no such thing as abstract Wayland. Every problem is specific to desktop environment (Wayland compositor in use, toolkit in use) and applications. If you give more details someone may be able to offer some ideas.

Ok, let’s give it a try with some screenshots. No idea why I’m not allowed to attach anything here, so I’ll use

A) shows the step 1 in signature process screen/tab. Drag&Drop of a PDF works with X11, doesn’t work with Wayland = nothing happens after Drop
B) shows the step 2 in signature process - positioning of the visual “signature” box via mouse. PDF file loaded in Step 1 is shown with content, scrollable, and “Signatur” box can be placed as desired.
C) shows the step 2 in signature process - positioning area stays empty, no content shown of loaded in step 1 to be signed PDF. “Signatur” box can’t be placed.

As I said, PDF is loaded also with Wayland # of pages shown correctly. Signature itself, technically/cryptografically takes place in step 3 and 4. Only (very) nice to have visual signature box, e.g. for the non-technical recipient of signed PDF, is not added.

Have you tried launching the app with the “QT_QPA_PLATFORM=xcb” environment variable set?

Does the app work using xwayland?

env XDG_SESSION_TYPE=X11 </path/to/app>

Thanks for helping!

Unfortunately no change. Tried with env … as suggested in .desktop file. As this .desktop calls a script, which starts the final java prog, I added a “export XDG_SESSION_TYPE=X11” line in this script. No effect.

There are several problems with Java Wayland interoperability, like X11 compatibility: Drag and Drop java → Wayland does not work. I guess you will have to live with it until it is fixed.

P.S. I tried switching to Wayland and each application I care about (Chromium, Thunderbird, QEMU, mpv, gnome-terminal) has issues in native mode (some just annoying, some critical). So almost all my daily applications run as X11 clients under Xwayland anyway which brings extra issues like copy-paste between Wayland and X11 clients.

Unless you have very compelling reason to use Wayland (i.e. something that requires Wayland) I think staying with X11 is less hassle for average users.

Thanks for the hint reg. JAVA interoperability, I’ll wait then.

I’ve made the complete vice versa experience than you reg. X11 vs Wayland. On my Leap Barebone, slow but noiseless, I’ve been affected by an unfixed bug since 15.2 ( which is TOTALLY annoying. Also X11 was only possible with xrender, very slow, as all OpenGL modes lead to freezes after some time. Also annoying. Got the feedback that this probably is based on incompatibilities with the built in Intel HD graphics card and the MESA driver.

Wayland itself have been freezing also with older Leap releases, but is now “rock solid” stable for me since 15.3. Drawbacks of course are missing / not ready support for several programs, like VNC server. Firefox and Thunderbird are working fine for me, I’m using Chromium not that often, that’s why no issues.