General question about hardware support

I updated the bios on my Dell laptop about a year ago (for the first time) and the keyboard function keys have not properly worked since then. Only about half of of them actually function. All the keys work fine in windows. How do I go about getting the new keyboard config supported in linux? I’m sure I’m not the only one having this problem. Unless I’m the only person running linux on a dell precision 7530, which I doubt.

Have you tried the system settings (if you are using KDE)? There’s a couple of DELL layouts (as well as generic) to choose from.

Also check the dell (wmi) modules are loaded;

lsmod |grep dell

Could be a wmi module bug as well…

Yes, the Dell wmi modules are loaded, and I tried various layouts in KDE settings. No luck. The keys died after a bios update. I’m 100% positive that’s what caused it. I haven’t been able to get them to work since.

If that’s the case, the create a bug report, include the output from the dmidecode output to the bug report. openSUSE:Submitting bug reports - openSUSE

Try to update BIOS.

I did, that’s what caused this problem to begin with. I updated it again in December, it didn’t fix the problem.

Does Dell in BIOS offer the option to downgrade i.e. can you download an older firmware and get back to where you were?
If you didn’t actually need that upgrade - just let it be.

Technically it does support a downgrade option, but I do not trust it to work and not turn the laptop into a paperweight. All the hardware works fine in windows, so this is still a linux problem at its core.

Some Dell laptops specifically support GNU/Linux - typically Ubuntu GNU/Linux. Have you checked the Dell site to see if your model Dell comes with Ubuntu support? If so check to see if the Dell site provides any guidance for GNU/Linux users? Also, if that laptop comes with Ubuntu supoprt, check to see if Ubuntu users had to adopt a specific approach with regard to the keyboard, in case the same approach is also applicable to openSUSE.

You state 1/2 the function keys are not working. Dare I ask, what half?

Which function keys are not working? Is your problem related to this bug report?

It does appear to be related to that bug. Just checked the system log after pressing the brightness keys, and I also get the ACPI errors mentioned in the report. As for the specific keys that are not working:

Function lock, microphone mute, scroll lock, wifi toggle, sleep, and brightness control.

Reference the brightness control, have you tried any custom boot codes? I have read for some laptops (and this is speculation on my part wrt openSUSE) that one might try in grub


If it doesn’t work, simply remove that. Post if you do not know how to apply such a setting to grub. Again - this is speculation to see if this code has any impact.

another code (instead of above) to try could be:


Again - these are just speculative ideas of things to try to work around this bug.

I’ve tried a bunch of possible workarounds, including the ones you mentioned, all to no avail. My laptop is supported on linux, but I can’t get Dell to actually address the problem because the laptop “came with windows.” I opened a bug report on, although I don’t know if it’ll ever get addressed. This seems to be a not uncommon problem from the google results I found.

I think I found the bug report you raised on I hope it results in a fix.

Best wishes and good luck on this.

There doesn’t appear to be much activity on that bug report.

You could also consider writing a bug report on openSUSE LEAP-15.2 - which if nothing else (if not solved by the openSUSE packagers), might have them point you to a better location to have attention applied to this bug.