General problem with a MATE process

Not sure if to post here or too chatty a topic. Fairly sure there is meat on it though so here I go.

Just a heads up if someone have noticed high cpu and ram usage with MATE. Is probably not because you messed up :slight_smile: Sometimes mate-settings-daemon go crazy. Simple as that. xsession-errors log fill up fast with entries like

(caja:5026): dconf-CRITICAL **: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.

I thought it was local problem, I am recent Linux virgin, but after some searching I doubt it. spell it out. Read from top. Solution for Mint users is apparently to uninstall systemd :slight_smile: Not for me. Bugzilla entry at RedHat is not too comforting. Is possibly fixed, then not.

Not sure this is linked to from github More of the same.

Can say it is first time I have seen it. Install is 3-4 days old. Had just finished setting up Apache, MySql server stuff which might have triggered something. Sadly seems like a general problem, quite old even.

Yesterday I saw much the same behavior with deja-dup-monitor process, also possible to Google info. Is one of those things, dev. cant reproduce - people disable = problem solved. Not so easy with this MATE issue. Might be connected with deja-dup.

Is **** because I just snatched the nice MATE theme from Ubuntu MATE and had it not been for this mystery deadly issue install would be perfect.

I actually used Ubuntu MATE for a week and had no problems but after reading about systemd that make sense. They, and MINT, are not on it yet. Ubuntu had other Ubuntu issues though.

Ubuntu MATE have these changes from newest MATE openSUSE not yet but I doubt they change much.


Do you have any other Desktop installed or did you do a minimal X + mate, as I installed kde4 first and I can’t get mate to run, I get infinite caja windows at start-up see
I noticed that there has been a new version of mate out 1.9 maybe the SUSE maintainers can build updated packages as the current are 1.8.1

I have not had that error.

Try installing “mate-polkit”. I don’t know if it will help. By default, there is no “polkit” agent running, and installing the “mate-polkit” package will fix that.

On one of my two MATE installs, I ran into a different problem, of infinite caja startups. But it was a different error message.

My other MATE install is doing fine. I had to install “mate-polkit” before I could configure WiFi.

Yeah got that one. There are some issues with MATE pattern where either a few items are missing or the entire Gnome mess gets pulled in if not careful. Some tabooing via Yast and having both eyes open fix this. Searching for “mate-” is good idea, may be also “caja-”.

After installing printer, printer settings “Unlock” button from ugly Gnome GUI was dead. Made me think of things starting with “Pol” - Yast delivered. Worked.

So after a bit of fiddling I think openSUSE MATE is healthy enough. Only need fine tuning. Would be cool if something was wrong there as that can be fixed.

I installed via minimal server so am wondering if things would work out if I first went with Gnome - then added MATE on top and cleaned up after Gnome. I doubt it but cant be 100% sure. Is most optimistic thing I have to say.

Have been trawling entire Yast and Google to find some magic fix. Nothing relevant left in Yast to tick and what I read about this just gets worse and worse. Seems like given right conditions you WILL see bug. Can scream all you like, not going to help. Is confirmed bug. Some will not have a clue until it goes wrong while others are waiting for it to strike again :slight_smile:

Look at when the bug was reported, how you can actually reproduce it - then how devs. react to it. Arguing with Poettering guy on RedHat bugzilla, Clem from MINT saying he hope no one laughs at his hacky workarounds, Debian bugzilla entry repeating what is already known. More importantly MATE devs. say nothing. Almost seems like after they figure this is a real nasty bug involving integration with what ever.

WHO is going to fix is also a question, good start? Bug was closed by Poettering so… And a nice comment on bugzilla where someone goes “Hey guys, bug is back on F21”. Eeeek. Because apparently an older systemd update was supposed to fix.

I said MINT does not use systemd. May be not but there are a few libs which when removed seem to fix this. Is not full blown systemd I guess, being Ubuntu based and all. I wont experiment with openSUSE and removal of systemd. How much it also mess up MINT is another question though. Clem says he already did work around problem, a few times even. So why it pops up and forum know-how suggest removing systemd? Questions, questions.

Anyway, is real nice DE which if not pulling in Gnome nonsense is near perfect. Is if not in to the others :slight_smile: Had it not been for other issues I might be tempted to use Ubuntu MATE where less systemd might hide issue.

Not in their interest to have such nasty open bugs at Debian, RedHat. I assume it is difficult for them to do much or they would have already. has like 3 tutorials on how-to install MATE. I think that guy also made the pattern and somewhere, may be on his site, he says issues “wont be fixed for 13.2, sorry”. I remember seeing that. I am not worried about openSUSE vs. MATE, will be perfect later. I doubt openSUSE integration is related to this ram/cpu eating bug.

MATE is doing fine on the box where I installed only MATE. I installed “minimal X” with the install DVD (64-bit), then added the MATE patterns later.

The install where MATE is looping in caja, is where I also installed KDE and Gnome. I don’t know if that is related to the problem.

Yep, same experiences here. Those install issues are what they are. Can be fixed. Not much to cry about had it not been for this bug.

Well, in next version or may be the one after that I could see openSUSE starting up offering KDE, Gnome - then under “others” it will be MATE and LXQT. If you check their github there is some activity going on, already new version out not yet in openSUSE and they are updating over and over. As for right now I am not comfortable with MATE though. Seeing computer die makes me hysteric and prone to assumptions. Not good and a bit of KDE until this is fixed wont kill me :slight_smile:

If annoyed about certain Gnome 3 eyesores check out Ubuntu MATE theme. Smells of Ubuntu but includes nice fixes. Ubuntu got a bit of special considerations I believe, official release and all… GTK 3 becomes like GTK 2.5 or something. Is acceptable. look for “ubuntu-mate-artwork - 0.3.7~trusty9”. “trusty” LTS version has latest tweaked theme. Works just as good on openSUSE :slight_smile: Can mix and blend away.

I got mate up and working, I used the info from
to make this short I installed all the packages listed in

sudo zypper in gnome-main-menu mate-backgrounds mate-control-center mate-dialogs caja mate-icon-theme mate-notification-daemon mate-polkit marco mate-session-manager mate-settings-daemon mate-desktop mate-panel caja-image-converter caja-open-terminal caja-sendto caja-share dconf-editor mate-dictionary mate-disk-usage-analyzer mate-icon-theme-faenza mate-netspeed mate-screenshot mate-search-tool mate-sensors-applet mate-system-log mate-user-share mozo python-caja atril engrampa eom gucharmap mate-applets mate-calc mate-power-manager mate-media mate-screensaver mate-system-monitor mate-terminal mate-themes mate-menus atril-caja caja-engrampa marco-themes mate-common mate-icon-theme-faenza-dark mate-icon-theme-faenza-gray mate-indicator-applet patterns-openSUSE-mate_basis pluma lightdm

and mate is up and running, I think there might be some packages missing in yast’s list
I hope this helps someone else.
I will reply in the other mate thread about the infinite caja windows as this fixes that bug.

Hello guys !

I’m the Mate maintainer, so I’ll try to answer to all your questions. About the patterns, you probably noticed they are incomplete. This is because the Mate software collection is incomplete too. My primary goal is to remove dependencies on gnome’ patterns.
About patterns errors, thanks for reporting these issues. They have been fixed for Factory, and will be soon for 13.2.


I just noticed another one yesterday.

I logged into MATE, instead of my usual KDE. This was after editing “.gtkrc-2.0” and commenting out the “oxygen” line to avoid the infinite caja problem (as suggested in a bug report). That worked. After a short period, there was a notifier in the panel telling me that there were updates available. Excellent.

Then I booted my laptop, with only MATE installed. I was never notified of updates available.

Whatever was notifying me of the available updates must not have been in the MATE pattern (maybe it came from Gnome).

There is an applet available for Mate. I’m working on implementing it.
For the Oxygen issue, it’s a knew probably which the fixing is in progress.

Just wanted to add I have been testing Debian Jessie MATE and the evil mate-settings-daemon process is also out of control there. Is not openSUSE issue but is seen in that too.

Fairly sure I triggered issue by using a plugin for Caja which lets you open file as root. Opened a file in MATEs archive manager, unpacked. Shortly after mate-settings-daemon was a 6.5GB and growing. 500+MB in .xsesssion-errors file.

Is not a new problem according to what I can dig up. Scattered but end result is the same.

Jessie runs with latest version 1.8.2-1, not sure if it matters with this problem.

I reported it to Debian so hopefully a MATE dev. notice and find a fix.

Not sure anyone will notice under click click usage so devs might not think it is that serious. Outcome is that is for sure. And not like it only show up doing edge case stuff.

They were fast so I quote from email. Relevant to MATE on openSUSE as well. Seems like users need to learn to love that command line and stop messing about with GUI as root :slight_smile: - guess that is WONTFIX! I do not buy that as Caja has a plugin specifically offering “run as root” feature but what ever. Not going to use Debian for long anyway. But possible “Bad practice” should not = ram being eaten until there is no more swap space.

On 12/12/2014 10:48 AM, Mike Gabriel wrote:
> Thanks for reporting this. I need to check on this. There were
> several upstream commit on various MATE components fixing memory
> leaks, recently. I will ask the upstream author of those patches
> what he thinks about pushing them into Debian jessie.

I’m not sure whether this can be trivially fixed. The problem is that
people are using “su -” to change the user and expect the X session
to change the user as well so that they can use desktop applications
running that new user.

However, the problem is that a desktop applications nowadays do a lot
of interaction using dbus, dconf and so on such that it becomes
problematic to run these from an su session even if you changed
XDG_RUNTIME_DIR for the new user which is probably why the systemd
people dropped this feature in the first place. I therefore more
or less agree with Lennart’s stance.

So, either these desktop applications should be able to work without
dconf, dbus in a changed environment or users should simply avoid
running these applications as root which is usually a bad idea
in the first place.

I usually use the terminal when working on system files. This way
you’re also more aware that you’re actually working as root.

It is a general rule that you should never ever log into a GUI as root. GUIs do lots of thing and touch lots of files and if done as root you can do great harm

Caja appears to be some sort of Web thing. Why would you want to run anything weby as root it is a serious security risk

I agree with that. But I don’t think that was the issue.

In KDE, the menus have an entry for “file manager in super user mode”. I think he was using the equivalent in MATE.

But the problem here was not caused by logging into the GUI as root.
It was caused by running an application as root inside the user’s GUI session.

Btw, this sounds like

Caja appears to be some sort of Web thing. Why would you want to run anything weby as root it is a serious security risk

Caja is a file manager, not at all related to the Worldwide Web.

Yes Caja same Dolphin, Nautilus, Krusader and what else there is.

I think I have seen a bunch of extensions for Nautilus allowing you to open files as root. When you want to edit them for example. May be it was old Nautilus.

If you click “Download new services” in Dolphin there is a “Simple Root Actions Menu”.

Nothing spectacular in this but apparently it does not fly too well with MATE with systemd in the background.

If this rooting from GUI, may be opening an archive thing which then do stuff as root too!, is an established fact then user should not have the option to do such action. Not enough to say “I personally use command line hence avoid problem”. Is a design bug.

Caja itself should definitely not offer a plugin doing just this either :slight_smile: Think it is this one - is not installed out of the box, may be for good reason.

Ok some web stuff came up when I Googled it. Guess a name clash

So in KDE you simply start with dbus-launch you don’t need a plugin.