General printing problems Opensuse 11

I am testing out Opensuse for my department at work to start using it over SLED. I have come into a bit of a problem with network printing.

I am trying to print through a Windows 2003 print server to an HP LaserJet 9040. I setup the printer through gnome print configurator and my cups settings in printers.conf look good. Test pages print and I am able to print from a few applications such as Acrobat, TomBoy, and OpenOffice. However, I cannot print from Firefox, Gedit, Gimp, Evince, or EyeOfGnome.

The symptom is by choosing File -> Print from these applications, my print button is greyed out with the 9040 selected. I can still print to file.

I have tried to setup a test user on the same system, thinking something may be wrong with my startup scripts, variables, or profile and the test user had the same problems. I have also tried using hp-setup for direct printing, but the same problem persists.

I’m trying to think of something these applications have in common, but have had no success. Please let me know if anybody else has had a similar issue or has any helpful suggestions.

did you try this
CUPS - Explained - openSUSE Forums

To caf4926,

I read through the link you gave and could not find any information pertaining to the symptoms I am receiving. If you posted an incorrect link, can you please repost with a correct link?

Again, my problem is where the print button is greyed out in specific applications. However, in other applications, printing is working as expected. Please see my original post in this thread for further details.

can i ask you why you did not want make HP laserJet 9040 reachable from openSuSE… why you use Windows 2003??? as a print server…
your printer is perfectly work with linux
OpenPrinting database - Printer: HP LaserJet 9040

I am never understand using Linux as desktop and using windows as server together…

if you setup you printer to linux… it will be so easy use it throw network… maybe you use another windows desktops in net.

The reason why we are using Windows2003 is that we are a large corporation with many departments and interests. At some point somebody said that Windows was going to be used as a print server. There are about 250 staff in our IT department. Therefore, the decision was not left with the *nix administrators.

Additionally, we have a requirement to print through the print server to get an approved cover page as about 40 staff use this printer.

Now, even if I print directly to the HP print serve port on the printer, the problem persists. Therefore, this is not an issue with the Windows print server.

The primary symptom is having some applications print okay and others have the print button greyed out. Please see my original post in this thread for details.