Geen toegang tot aantal partities (dataopslag)

Beste forumleden,
Ik ben een nieuwe gebruiker van OpenSuse, komende van enkele jaren Ubuntu gebruik.
In een ver verleden heb ik nog Suse gebruikt, begonnen met 7.0 en gestopt met 9.10, maar daar weet ik niet zoveel meer van.

Bij de installatie (met life cd) van OpenSuse 12.1 (32 bit en Gnome) kon ik zien dat het programma al mijn partities met dataopslag (Fat 32 en NTFS) kon zien en een letter gaf.
De partities hebben anders hun eigen labels, die ik ze gegeven heb om ze te onderscheiden, maar die zag ze niet.
Nu ik het systeem draaiende heb kan ik nergens die datapartities vinden. Wel de partities waar andere Linuxversies op staan en waar ik dus niets mee doe als ik hier in Suse zit.
De datapartities heb ik wel nodig.
Wie kan me helpen mijn partities weer te vinden, te openen en te gebruiken?

Veel dank bij voorbaat.
Als je meer info nodig hebt, vraag maar op.

Dag, welkom hier.

Dit kan gefixt worden, we hebben alleen wat output van je nodig. Post die alsjeblieft tussen CODE tags, anders worden dingen zo onleesbaar.
Open een terminal venster en post de output van:


su -c 'fdisk -l'

cat /etc/fstab

cat /etc/filesystems

Normaal gesproken zou je je windows partities terug moeten vinden in /windows/C Nz. Als ze daar staan, gaat het dus alleen om lees/schrijfbaar maken.

Hoi Knurpht, bedankt voor je antwoord.
De map Windows gevonden (wie komt er op het idee om zo’n map “windows” te noemen? Mijn computer heeft al jaren helemaal niks meer met Windows. Dat Suse dat vroeger ook al deed was ik vergeten…
Ik kan overal in en alles gebruiken.
Heb wel nog een bijkomende vraag: hoe kan ik die letters C tot en met I terug de namen geven die ik ze eerder gaf als label ? In de bestandbrowser gaat dat niet (rename staat grijs)?
Nu moet ik hier een lijstje ophangen met de letters en daar de namen achter :shame:

Dat kun je veranderen in /etc/fstab, daar staan de aankoppelpunten in. Uiteraard mag je de naam daarvan niet veranderen terwijl de boel in aangekoppeld. Dat zou zoiets zijn als je huisnummer veranderen terwijl de postbode al in de straat loopt.

Doe je dit liever via de grafische interface, kies dan Yast - Systeem - Partitionering, wijzig de aankoppelpunten van de windows partities zoals je ze graag hebben wilt. Je moet dan wel eerst de aankoppelpunten aanmaken, en de juiste permissies geven.

Nu heb ik iets gedaan wat niet mocht denk ik, maar voor ik de namen weer ga veranderen toch eerst kijken of het niet anders kan opgelost worden.
Ik heb de mapnaam “windows” ook veranderd en dat in de naam “OPSLAG”, met daarachter hun specifieke mapnamen.
De bestandsbrowser laat erchter nog steeds “windows” zien met daarachter de C, D, E enz., allemaal lege mappen dus.
Bij het veranderen van de namen heb ik eerst al die schijven afgekoppeld.

Ziehier mijn cat /etc/fstab:

linux-nydc:/home/lieve # cat /etc/fstab
/dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL598907-part7 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST3250310AS_6RY6BDC1-part6 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST3250310AS_6RY6BDC1-part8 /                    ext4       defaults              1 1
/dev/disk/by-id/ata-ST3250310AS_6RY6BDC1-part1 /OPSLAG/TRIAL        vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/disk/by-id/ata-ST3250310AS_6RY6BDC1-part2 /OPSLAG/MOTO         vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL598907-part5 /OPSLAG/PICS         ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=nl_NL.UTF-8 0 0
/dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL598907-part9 /OPSLAG/DATA         ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=nl_NL.UTF-8 0 0
/dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL598907-part10 /OPSLAG/FOTO2        vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL598907-part11 /OPSLAG/FOTO1        vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL598907-part12 /OPSLAG/DATA2        vfat       users,gid=users,umask=0002,utf8=true 0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

Dus ipv. OPSLAG weer om te zetten in “windows”, kan ik het besturingssysteem ergens wijs maken dat het nu OPSLAG is dat die moet aankoppelen?

Dat kan zeker. Ten uitleg: je hebt nu wel aangewezen, dat de partities elders aangekoppeld moeten worden, maar dat “elders” bestaat niet. Dat doe je zo


su
mkdir /OPSLAG
mkdir /OPSLAG/TRIAL
mkdir /OPSLAG/MOTO
mkdir /OPSLAG/PICS
mkdir /OPSLAG/DATA
mkdir /OPSLAG/FOTO2
mkdir /OPSLAG/FOTO1
mkdir /OPSLAG/DATA2
mount -a

Het “su” commando geeft je root-rechten, de “mkdir” commando’s maken de mappen aan, het “mount -a” koppelt alles uit /etc/fstab aan dat niet al aangekoppeld is.

De kabouterkes zijn langs geweest, toen ik vanavond mijn pc weer opstartte stonden de mappen er wel. Of ik heb daarstraks slecht gekeken lol!
Die andere mappen staan er ook nog, dus die ga ik nu dan maar verwijderen.

Heel fel bedankt voor je hulp !
Er gaan zeker nog vraagjes komen, maar dat is voor later.

Groeten en fijn weekend nog.

Ik begrijp hieruit, dat dit stuk in ieder geval naar behoren werkt.

Ja, alles wordt meteen gekoppeld bij het opstarten en ik kan alle schijven gebruiken.
Ik krijg wel iedere keer bij de opstart onderaan het scherm een melding dat een schijf vol zit. Ik weet dat ze vol is en ik schrijf er ook niets meer op.
Kan ik ergens die melding voor deze schijf uitzetten?

Heel kort: dat kan vast wel, maar ik vind dat geen oplossing. Zoiets als een lekke benzinetank, en dan de draadjes van de brandstofmeter doorknippen. Juist op NTFS schijven is het zaak om ± 1/3 vrij te houden, omdat je anders allerlei redmiddelen niet meer ter beschikking hebt. Daarbij denk ik dat je dan ook geen meldingen meer krijgt over andere schijven die vollopen.
Kun je eens output posten van


df -h

Oke, dan laat ik het misschien zo en zal de schijf eens opruimen, er staat waarschijnlijk toch een hoop op wat ik niet meer nodig heb.

Edit: toch even de df -h gedaan, interessant zoiets, je kan zo heel snel in één oogopslag van alle schijven zien hoe vol ze zitten.
Er staat er nog eentje al op 85% en een andere op 95%. Het wordt stilaan tijd voor een nieuwe harde schijf (ik fotografeer en film veel).
Vroeger had ik dat meer in de gaten omdat Nautilus onderaan het scherm altijd aangaf hoeveel schijfruimte er nog was op de geopende partitie. Nu is dat niet meer.

Is er niet ergens een optie, waarmee dat weer zichtbaar wordt?

Yep, na lang zoeken en niet vinden in de preferences heb ik het dan toch gevonden onder “view”: statusbalk aanzetten. Zo simpel was het :stuck_out_tongue: Die info staat dus gewoon in de statusbalk.

Maar nu heb ik andere problemen. Na een grondige update is mijn systeem niet meer bruikbaar, krijg een mooi “Oh no…” schermpje. De boodschap “Please contact a system administrator” interpreteer ik dan maar als: contacteer het opensuse-forum :wink:
Het verbaast me eerlijk gezegd niets, het is al weken zo dat mijn Ubuntu systemen vastlopen na updates en nu zag ik bij de Suse update ook “NVIDIA” voorbijkomen en dacht meteen “ai, dat wordt miserie”.
Ik was ook mijn grubscherm waar alle andere distro’s op staan weer kwijt, maar dat los ik tegenwoordig met een life cd van ubuntu in tien minuten op.
Ik start later op de dag een nieuw topic, als dat nog nodig is. Ik ga eerst zelf wat zoeken.

Je moet de NVIDIA driver opnieuw installeren, denkelijk “met de hand”. Ik zoek even, heb net gisteren nog een post in de engelse forums geschreven over hoe je dat doet.

En ach, kijk eens wat ik vind: http://forums.opensuse.org/nederlands-dutch/community/nl-how-tos/474279-nvidia-driver-op-opensuse-12-1-handmatige-installatie.html

Die pagina had ik al eens gelezen, maar ik kan dit toch niet doen omdat ik helemaal niet meer in het systeem geraak. Hoe kan ik dan in Yast dingen aanpassen of mappen maken?
Als ik Open Suse failsafe opstart krijg ik een zwart scherm met een prompt. En daar ken ik helemaal niks van.
Of kan ik nog iets met de lifecd die ik voor de installatie gebruikt heb?

Ik word hier zo moe van he, naast Open Suse zijn op één na alle Ubuntusystemen hier al onbruikbaar, Fedora 16 met Gnome 3 die ik vorige week probeerde ook al en dit iedere keer na die verdomde updates.

Zou het beter werken als ik de 64bit versie installeer? (heb AMD64bit moederbord) Maar het blijft natuurlijk nog NVIDIA…

Geen paniek, je zit op openSUSE, en één van de mooiste dingen die openSUSE heeft is Yast. Dat draait namelijk niet alleen op de desktop, maar ook, in de zogeheten “ncurses-modus” in een termina of console. Log in met je gebruikersnaam en wachtwoord, en doe dan


su -c yast

Je krijgt een blauw scherm te zien, waar je doorheen kunt navigeren met de TAB en pijltjes toetsen. Op die manier kun je de benodigde pakketten installeren. In dit geval los je met een LiveCD niets op. De X-server “ziet” nl. een bestand van de NVIDIA driver gewoon staan, en “denkt” dus dat die gebruikt moet worden. Maar door de kernel-upgrade die je gehad hebt, staat de driver module waarnaar dat bestand verwijst er niet meer.

Ik ga dit zeker proberen. Ik had het vroeger al eens gedaan (Yast starten met su) maar dat was ik alweer vergeten.
Is die -c er bij latere versies bij gekomen? Ik dacht dat het vroeger gewoon was: su enter, wachtwoord en dan Yast starten, of was het toen nog sax2 of zoiets?
Heb toen ook veel miserie gehad om het scherm van mijn Toshiba laptop draaiend te krijgen.

Nu heb ik een paar dagen geen tijd, maar ik hou je zeker op de hoogte over de afloop.

Ik kom uit de UNIX hoek van oorsprong, en leerde van een trainer: “Root, neuh, nergens voor nodig, je hebt alleen root’s rechten zo nu en dan nodig”. Die was falikant tegen " su ", als 't dan toch moet " su - " (het minteken zorgt ervoor dat paden etc van root worden ingelezen en toegpast), maar liever alleen " su -c " gevolgd door wat je wilt uitvoeren, en dat dan tussen enkele aanhalingstekens: De rootpermissies gelden dan alleen voor het ene commando, of script.


su -c 'tail -20 /var/log/messages'

laat de laatste regels zien van een bestand dat gewone gebruikers niet mogen lezen.

Als je “su” doet, enter, password en dan Yast2 opstart, is de interface gewoon die van de desktop van de ingelogde gebruiker.
Als je “su -” doet, enter, password en dan Yast2 opstart, is de interface in het engels, omdat dat dat de default taal van root is.

Ik ga leren werken met su -c, dat lijkt me veiliger.
Vroeger logde ik -wanneer ik iets moest veranderen aan het systeem- altijd als root in SuSE, omdat ik het zo geleerd had. Je kreeg dan een bureaublad met bommen op de achtergrond :open_mouth:

Nog een vraag over de “default taal”. Dat is Engels, maar hoe is het toetsenbord dan (ervanuitgaand dat ik dit ook krijg bij su -c programma)? Want ik zit hier op een Belgische azerty, bij qwerty weet ik veel tekens niet staan. Is het toetsenbord in dat geval in console even snel om te zetten? Waarschijnlijk ook in dezelfde Yast of met een commando? Herinner me vaag iets van “latin”.

Voor installatie moet volgens je howto herstart worden in runlevel 3 dmv. F5.
En mijn Grub doet niets met F5. Kan wel in de regel van Suse failsave gaan staan en dan “e” drukken. Dan krijg ik iets met regels die aangepast kunnen worden voor de opstart. VGA staat er ook. Daarachter dan gewoon cijfer 3 typen?

Lastig, want niet na te doen, omdat ik hier niet zulke toetsenborden heb.

Maar…ook in Yast - Hardware - Systeemtoetsenbordindeling (wat een woord) kun je “zetten” wat voor toetsenbord je hebt
Om in plaats van systemd System V’ init tegebruiken kun je ook op de regel achter vga=… dit zetten:


init=/sbin/sysvinit

dat doet precies hetzelfde als F5 en dan System V