I am trying to do a fix I read in another post however I am having a problem running gedit.

if I type

gedit sysctl.conf

it works fine, however I wouldn’t be able to save obviously, so I typed

sudo gedit sysctl.conf

however once I added sudo it wouldn’t open I get this.

cannot open display: 
Run 'gedit --help' to see a full list of available command line options.

I really don’t know what I’m doing wrong here.

You need to use gnomesu rather than sudo

gnomesu gedit /etc/sysctl.conf

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel
up 1 day 10:57, 1 user, load average: 0.22, 0.42, 0.28
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Thank you very much! I guess it’s obvious I recently switched from a different distro. I just need to get used to some of the differences. Thank you again.


Another option would be to enter:



gedit /etc/sysctl.conf

or you could use vi or emacs:

sudo vi /etc/sysctl.conf


sudo emacs /etc/sysctl.conf

Take care,