gEdit crashes in super user mode

Hi all, Me again…

So I created a button to go directly to the file manager in super-user mode (with the help of this community, thank you, you guys ROCK!), but having a small issue… When I open a file to edit the text like php.ini or the phpadmin config file, it goes directly to gEdit. There are no other options and there does not seem to be another text editor for Gnome. The problem is that gEdit will start to open then crash and close. If I open these files in the non-super-user file manager they open fine but will not save.

Any fix to this? I have tried the default install version, the update and nothing seems to fix this. After numerous installs of Tumbleweed, I finally got most things working (yes, I’m very new to Linux lol). so I really do not want to do another complete install.

Thanks in advance,
Michelle :slight_smile:

I would have thought;

 gnomesu -c /usr/bin/gedit /path/to/some/file

In saying that it may change the ownership as would have thought you php files are owned by www?

Hi Malcolm… Do I add that line to the desktop file for the superuser link? This happens when I use the file system, nautilus I believe, in super user mode. I go to the file itself and click on it to open it. It happens in all directories… I tried it in a theme file as well. But in the regular file manager gEdit opens just fine but will not save… as it shouldn’t since it is not superuser.

The shourtcut (aka desktop file) would not include the path bit.

Press alt+F2 and run the command and see how that goes, you would need to use file open then browse to it.

So there is no way to do this like with KDE where you do not have to know where things are and type so much?

I do all my editing of system files via command line and vi, helps when you on a system with no desktop… or stuck in maintenance mode…

Well each DE has it’s own requirements, philosophies and quirks… alt+F2 is the way to start things up the easy way (note tab completion works) else via a desktop shortcut, or command line…

Remember things like apache, postgresql and PHP etc are system services, nothing to do with desktop environments, that’s why some things are done via YaST.

So, do you want a shortcut to just open gedit, or gedit with a specific file as super-user?

Coming from windows, I am use to one clicks. So creating that icon link to get into super user mode was my solution. Kinda like KDE. Anytime I had to edit something I just used the super user mode and things worked fine.

Yes, the command line thing is like Japanese to me, if my system crashes and I cannot get into the desktop i just reinstall cause I don’t know any other way to get it back. LOL.

I guess I just do not understand why KDE does this without flaw and Gnome has issues… they are both opensuse. I guess it’s a desktop thing and not a linux thing. Oh well.

My work around was to copy those two files I was having issues with to my home directory and edited them there then copied them back. LOL.

I guess that is what I will do. I wish Inkscape worked with KDE, it seems to be more user friendly. Oh well. :slight_smile:

PS - Thanks for the link, I have it bookmarked. Useful info there :slight_smile: