Gecko-mediaplayer and Konqueror

Does anyone know if it is possible to use Gecko mediaplayer with Konqueror? I use it with Firefox to watch web-tv and that works fine, but I would prefer to use Konqueror. I have tried Konqueror with KMplayer but I can not get it to work properly, A/V is often clicking and of rather poor quality.

Not that I know of
And K generally sucks compared to Firefox and GeckoMP is the replacement for the Mplayer firefox plugin. It makes sense to use FF

Perhaps you’re right but I like Konqueror and have always used it, besides it is, I suppose, better integrated with KDE and it certainly is faster. I hope it keeps on developing and increases its usability, therefore I use it.


In konqueror if you scan for plugins, it is showing the gecko-mediaplayer


Yes I know, but it isn’t working (not for me at least).

It was the same for me - like you konqueror is my prefered browser, but no joy. Gecko mediaplayer works fine with firefox & chrome but not with konqueror.

Hi guys,
What’s the better way to test it to know that it is not working.
I want to try konqueror. I don’t watch web tv.
A while ago I tried to play quicktime movie thriller and at least it played in konqueror
while I can’t play it in firefox. In firefox, quicktime movie thriller loads and stop.

All-right, the web-TV which I use the most is this (NRK Norwegian broadcasting): NRK Nett-TV. I get the option to choose whether to watch with Silverlight or Windows media player, I choose Win player so I suppose it is a wmv(?) stream I’m viewing. By the way, anyone of you who use Moonlight successfully? I am unable to watch anything if choosing the Silverlight option from this site, but I haven’t tested very much around elsewhere. This is the case whether I use Firefox or Konqueror.

Hi F_Sauce,
I could be wrong but I found gecko-media player work in konqueror.
There is a stance that I open kong and try to play video and there was a pop-up
saying gecko-media player failed to start and ask if I want to start it when I click to start
the video played.

Your link doesn’t work here in firefox and konqueror.
I removed all the plugins in konqueror and manually add again
and still no joy in that site.

I installed 12.2 Milestone 2 (updated using the factory repos) yesterday and tried gecko-mediaplayer with konqueror. It worked fine with apple film trailors but when I tried the Norge TV station - it just opened kaffine and did not do anything am afraid.

Hello dth2 and conram!

I’m getting familiar with the KMplayer plug-in which now works OK with Konqueror on the site in question. It seems like there are some initial troubles when loading videos but after some time (sometimes up to a minute ++) the lagging and clicks stops, and the video usually plays fine. Firefox and gecko also has some issues on this site, most notably that the video stops if one tries to pause it, this does not happen with KMplayer though the synch of audio and video sometimes get off track. This is at least my experience so far anyway.