gdm weirdness after update to 11.1

Hello,

I have updated from 10.3 to 11.1 this weekend. I used the update feature of the OpenSUSE DVD. Everything seemed to go smoothly, the system seems to work fine except one important thing: when I start gdm, instead of presenting a chooser, it directly logs me in as the ‘gdm’ user. It happens on startup, when I have gdm installed. If I go to tty1, kill gdm, login as myself and run startx, I get my desktop, and everything seems to work fine. If I login as root instead, and start gdm from the command line, it again logs me in as ‘gdm’.

I can remove gdm and use xdm instead, but I would rather have gdm back, especially since with xdm, NetworkManager does not seem to be starting.

I tried to google the problem, but I couldn’t find anything remotely like it.

The gnome team went KDE4 on gdm for the 2.24 release it seems (senseless rewrite with greatly diminished functionality).

It seems that 11.1 enables autologin by default (not smart). In yast, go to /etc/sysconfig editor->desktop->display manager and unset DISPLAYMANAGER_AUTOLOGIN.

The configuration options for the new gdm are thin at best.

Hi
There have been a few changes…
http://library.gnome.org/admin/gdm/2.24/configuration.html.en


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-pae
up 9:54, 2 users, load average: 0.13, 0.08, 0.15
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

No kidding. The latest Gnome releases are almost making me nostalgic for the good ole CDE. Even though that time, it took me whole 5 days to figure out how to keep fvwm as window manager, this time I managed to do it in one day. I must be getting better. :slight_smile:

It seems that 11.1 enables autologin by default (not smart). In yast, go to /etc/sysconfig editor->desktop->display manager and unset DISPLAYMANAGER_AUTOLOGIN.

The configuration options for the new gdm are thin at best.

That’s not it. I checked, and it was already unset. Either it came that way, or I did it when I was digging there before heading for the forums, I don’t remember. But things are getting interesting nevertheless:

When looking at the sysconfig options, I decided that since gdm apparently wants to autologin, it can just as well autologin me instead of gdm user, so I set DISPLAYMANAGER_AUTOLOGIN to my username, restarted gdm, and … nothing. The same behavior as before.

I already noticed before that on startup, gdm complains about not finding /etc/gdm/custom.conf. I didn’t pay much attention to that, as I previously completely re-installed gdm from the package, and assumed that if it was needed, the package would install it. Anyway, all the relevant settings seemed to be in sysconfig. Now I decided to create a minimal custom.conf, following some documentation I found on the web (pretty much the same file malcolmlewis posted, thanks), like this:


[daemon]
TimedLoginEnable=false
AutomaticLoginEnable=false
User=gdm
Group=gdm

As you can see, I specifically disabled timed login and automated login. Then I restarted gdm, and, couriouser and couriouser, I was autologed into my account. Then I tried to go to sysconfig and unset DISPLAYMANAGER_AUTOLOGIN. After that, gdm returned back to the original behavior, loging in as gdm.

At least I can now autologin to my account. It’s not optimal, but I can live with it.

But it gets better: when I now log out, I should get the greeter. Instead, it logs me in as gdm. My conclusion is that

  1. gdm needs custom.conf in order to pay attention to the settings in sysconfig, and the package does not seem to install one.

  2. when gdm tries to start the greeter, it for some reason logs in the gdm user instead. Based on what I described above, I don’t think it is trying to autologin gdm user, I think it is trying to start the greeter, but fails.