GDM w/o Keyboard

I have Lenovo T61 with opensuse 11.4 which until this morning was working just fine. I have used OpenSuse on this notebook for about 2 years with out much trouble.

This morning on boot up I could not login because GDM was not listening to the keyboard for some reason. I rebooted on a live disk and the hardware was just fine. I switched to init 3 in /etc/inittab and the keyboard was working fine. If I started X with startx it still worked fine. If I started gdm the keyboard was not working anymore, so much so that I could not do {ctrl}{alt}{F1} to switch to a virtual terminal or {ctrl}{alt}{bksp} to kill X, nothing. The mouse worked so I could reboot.

I installed KDM and switched to it instead of GDM for the display manager with yast and was able to login and everything is fine.

I would like to switch back to GDM but it is not that big of a deal, but if anyone knows what this is caused by please post.

Thanks in advance.

Oh BTW - I am not on Gnome 3

rpm -q gdm

Twice for some reason when I’m in GUI init 5, my keyboard preferences for mouse setting is changed to set to use pointer controlled by mouse and none of the keys work.