GDM doesn't work

I’ve installed opensuse 12.3 and then updated to Tumbleweed in order to have a rolling distro. I’ve done the 416 updates and zypper gave me no errors. After I rebooted the pc, gdm stopped working and the boot stops at
OK ] Reached target Graphical Interface
During the boot i can see the splashscreen of the green chameleon, so i don’t think this is a Graphic problem. I use a notebook with an Intel graphic card GMA4500HD.
Before using Tumbleweed everything worked.
If i get into a shell and type “systemctl status gdm” it says:
Loaded: error (reason: no such file or directory)
What should I do?

when booting try Advanced==>Recovery mode

I tried now and I can see a shell login.
I tried to type startx and it says fatal error connot copy some files (i don’t remember).

If you can see login, did you try to login ?
startx is i believe deprecated.

I see a console login (like control alt f2).
I tried to login and it worked, but the problem is there’s no gdm nor gnome-shell, so I can’t use openSUSE.
Could the source of the problem be that i removed some junk files with bleachbit?
I tried reinstalling gdm, x11, intel video driver.

i do use bleachbit for years now but if you launch in admin mode and add some presumably unwanted files then it cause wreak havoc.
I once removed /tmp using bleachbit in “admin” mode

Since you are using tumbleweed you should move the post here

Click the triangular icon at the bottom of each post to move the thread. Best of luck.

On 05/25/2013 10:06 AM, Tomoms wrote:
> updated to Tumbleweed

all problems with Tumbleweed are to be posted to the Tumbleweed
forum…please click the triangular shaped icon at the bottom of
this window pane and ask a moderator to move the thread to the
correct spot…



GDM is started by the xdm init script so you should run “systemctl status xdm”.

As for your original problem: Some branding packages have a lower version in Tumbleweed, which apparently causes incomplete updates because of dependency errors. This results in an incompatible mix of packages.
Try running “zypper dup --from Tumbleweed” and in the conflict resolution thing that appears always select “downgrade”. That should fix your problem, I hope.

Moving thread to Tumbleweed in a few minutes NNTP stay clear

ahhh, this thread should be in Tumbleweed. Sowwy

OK, zypper dup --from Tumbleweed worked!
Thanks for your help!
So now, when I want to check for new updates and install them what should I do?
zypper dup (I think it’ll mess up everything again), or
zypper dup --from Tumbleweed, or
zypper up (now it shows 35 updates saying that they aren’t going to be installed.)

As long as you don’t change the repo priorities, or the Tumbleweed repo gets those packages in a higher version, “zypper dup” will want to switch back those branding packages (and others as a result) to the standard 12.3 versions. So the system will be messed up again, yes.

zypper dup --from Tumbleweed, or

If you use that, you won’t get updates from the standard update repo and Packman, but otherwise you should be fine.

zypper up (now it shows 35 updates saying that they aren’t going to be installed.)

That’s normal, that 35 are those packages that have a higher version in the standard repo, and you don’t want to switch them back.
“zypper up” will work because it doesn’t switch repos, but as a result of that you won’t get new packages that are added to Tumbleweed. So this is not really the way to go either.

So you should use a combination of “zypper dup --from Tumbleweed” and “zypper up” to always be current.

But I think the best thing to do is change the priority of the Tumbleweed repo (and Packman if you have that) to 98 in YaST->Software->Software Repositories, and continue to use “zypper dup” to update…

Ok. You said that I’ve got to change the priority of tumbleweed and packman in yast. Do I have to change priority also of Current-Update Current-Non-Oss Current-Oss and Current-Update-Non-Oss? What are these repos for?
Thanks for being so patient!

On 05/25/2013 02:06 PM, Tomoms wrote:
> So now, when I want to check for new updates and install them what
> should I do?

this page (which is
written by the guy who invented and still controls Tumbleweed) says:

The only supported method of repo use for Tumbleweed is to have only
the main repos (Oss, Non-oss, and Update) and the Tumbleweed repo
active. For that situation a simple

sudo zypper dup

will update your packages, and if any packages are ever reverted from
Tumbleweed zypper dup will also handle that.

Despite it being unsupported, if you do choose to have other repos
enabled, this command is safer:

sudo zypper dup --from Tumbleweed

but don’t stop by just reading this answer because there is more
information there…look to the source Luke (and you will see how
[for example] to allow the vendor change and other facts–like there
are situations where Tumbleweed is NOT recommended, and who should
try it, and who should not…be sure and read that part to.)


No, you should not. Otherwise you will have the same problem again. (Although I’m not sure if those branding package are in the update repo at the moment, but they could be added anytime)

What are these repos for?

  • Current-Update is the standard openSUSE update channel
  • Current-Non-Oss is the standard repo for nonfree software like flashplayer, Adobe Reader and Opera.
  • Current-Update-Non-Oss is the update channel for Current-Non-Oss.

Thanks for being so patient!

You’re welcome! :wink:

Right, the page says that. But the premise for that working is that all packages in Tumbleweed have a higher version number than the ones in the standard repo. And that isn’t the case at the moment for some branding packages. (f.e. gdm-branding-openSUSE, gio-branding-openSUSE, gtk2-branding-openSUSE, and so on…)
And because of dependencies, right now “zypper dup” apparently causes messed up (GNOME) systems.

Maybe someone should report that as bug? (I don’t care, since I don’t even use Tumbleweed…)

Ok. So, if I understood well, now that I’ve got Tumbleweed repo and pakcman repo with priority 98 and Current Non Oss, Current Update and Current Update Non Oss with priority 99 I’m ok and I have a rolling and up-to-date opensuse, right?

Right, but only if you run “zypper dup” regularly…:wink:

Ok, now you can even close this thread.

On 05/25/2013 07:06 PM, Tomoms wrote:
> and I have a rolling and up-to-date opensuse, right?

well, not really!

Tumbleweed is not a real “rolling release” if you use the common
definition and understanding of what a “rolling release” is…

most folks think a rolling release is one which rolls out new parts,
pieces, applications, kernels, patches and updates continuously to
feed an ever newer but coordinated singularity, no parts of it ever
being considered needing replacement…

in other words a “rolling release” does not release a new numbered
version (including new application versions) every once in a while.

using those ideas openSUSE is clearly not a “rolling release” and
since Tumbleweed will (every 8 months) go though a complete version
upgrade exactly when openSUSE does, it is not a true “rolling
release” and in fact in the source document about it
<> does not call it a “rolling release” but
instead “The Tumbleweed project provides a rolling updates version of

so, each 8 months all Tumbleweed users move to the latest version of
openSUSE and then as the next versions applications, parts, pieces
and etc have been ‘tested’ some in Factory, they are rolled into
Tumbleweed, until the new non-rolling version is installed…