GDM does not start (Nvidia proprietary)

So it has been a while since GDM stopped working on my end. I’ve workaround it by using LightDM, but as I’m back to using Gnome making GDM work seems like a good idea.
I have no clue where to start looking though. Tried reinstalling gdm, removing nouveau (I’m using proprietary driver from the official repo) - no luck.
Any ideas?

GDM now uses Wayland by default and Nvidia doesn’t like Wayland.
Try to uncomment the line reading “#WaylandEnable=false” in /etc/gdm/custom.conf and reboot.

thx @OrsoBruno ! Unless I’ve did something incorrectly that didn’t help (side note - how I wish Nvida folks had grown up a tad and adhered to specs made by Wayland team → one of the reason my next GPU probably won’t be a green team one).
Gdm is still stuck at:
I’ve tried both auto option and manual in update-alternatives --config default-displaymanager :
Just in case here’s a screenshot from the grub as well:

Let me know if there’s some other info I should provide to sort it out.