gcc cannot find -lperl

I’m getting compilation errors due to gcc being unableto find -lperl. Here are the packages I have installed:

perl-XML-SAX-Expat-0.50-3.2.noarchperl-XML-NamespaceSupport-1.11-23.1.x86_64
perl-XML-SAX-Base-1.08-10.1.noarch
perl-XML-LibXML-2.0019-5.6.x86_64
perl-base-5.18.2-3.5.x86_64
perl-Bootloader-0.844-1.1.x86_64
perl-SNMP-5.7.3-4.1.x86_64
perl-5.18.2-3.5.x86_64
perl-XML-Parser-2.41-23.4.x86_64
perl-XML-SAX-0.99-24.1.x86_64
perl-Term-ReadKey-2.31-3.6.x86_64
perl-Error-0.17021-3.2.noarch

I believe I can fix the issue by creating a link myself:

ln -s /usr/lib/perl5/5.18.2/x86_64-linux-thread-multi/CORE/libperl.so  /usr/lib64/libperl.so

However, logic would dictate I’m missing some sort of development package but I cannot find anything. Is there a perl devel package available on OpenSUSE?

Hi
It’s a pattern rather than a package;


zypper in -t pattern devel_perl

But it should find that with whatever you compiling looking at the perl version installed? Maybe a missing configure option?