Gash some how write protected usb sticks

I have had a couple of problem usb sticks. One supplied free when I bought a couple so it looks like some one else has had the problem 2. I formatted them on a windoze lap top as it was handy at the time and thought I had used vfat but when plugged into a linux machine they show as unsupported format ???/NTFS, can’t remember the letters where the ??? marks are and don’t want to risk another. So formatted ext2 as suggested on a kde info site using volume lable for ID, user mountable and no mount on boot. It’s trashed the stick and what ever I do causes write protect errors to pop up even on windows. They are 65gb sticks. Also tried ext3 on another. Same result. I like volume label mounting as it tells me which one it is.

I wonder if anyone knows of a fix for this? It seems to be a fairly common problem but solutions are mixed and don’t seem to work.

I have had one thought having used the technology at a low level. I suspect 0 has been written to the wrong place in it. I assume it’s 0 as the erased state is usually $0FF however the logic in the stick might invert that when it comes out.

I wonder if it’s possible to forcible fill a portion of it with $0FF or 0 from the console. GParted is currently scanning it for files. Having formatted it btrfs it does sort of mount now but I get write protect errors still what ever else I try. I hoped btrfs format was a little incomplete and as it didn’t spot write protect looks like it is. I though that doing this might allow me to format to something else.

Whoops $0FF hex is 255


if you want usb drives to be used on both openSUSE and windows then do this How to Format USB drive using YaST partitioner on openSUSE 12.2, GNOME 3.4.2 - YouTube

On 2013-07-09 14:26, John 82 wrote:
> I have had a couple of problem usb sticks. One supplied free when I
> bought a couple so it looks like some one else has had the problem 2.

Check syslog to see how they are identified.

There is a type of usb “standard” where the stick is protected by a
password. AFAIK, it is not supported in Linux.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

As the problem seems to have started on windows I searched for any microshaft comments on it. There are lots and lots of comments on the web about it. Note 'shafts response to “read-only state” rather than “read-only” being set. Checked with dos and loh read-only state has been set some how

USB Drive Read Only

Linux follows the same rules.

There is a fix after a fashion. A USB stick site speed tests them and lists the VID and PID which is used to identify the make of the control chips. A Russian site has a number of different utilities that will set up some of the chips that are about correctly but not all of them unfortunately. There are lots of web based instructions for fixing this but basically none of them work unless the stick has been set in plain old ordinary read-only.