Garbled screen on startup

Hi, I just installed openSUSE 11 and am having a few issues. When I booted up for the first time (and subsequent restarts) I am having a garbled display. Here is a screenshot:

My monitor is a 24" LG LCD at 1920 by 1200. My graphics card is an ATi Radeon X800XL. I chose KDE 3.5 during the install if this is relevant.

EDIT: I forget to mention that what I think is meant to be white on the screen is rather purple. I don’t think it’s a problem with the screen, because it doesn’t do this with Ubuntu or my Xbox.

If someone could help me out with this it would be much appreciated. Thank you,


It seems like this might be a driver issue:

Since it seems that the driver, or lack of it in this matter, is causing the problem, let’s see if in installing the driver will fix it. The driver for ATI cards can be found on OpenSUSE Wiki ATI page. The first section on the page will have a 1-Click Installer: click the image to download the installer. Once the installer has been downloaded, it should start the process by default (if not, then right-click the download package in the Firefox download window and click Open). When it opens, YaST will walk you through the installation process, step-by-step. Once you have installed the driver, reboot your system. When you get to the boot screen to select which Operating System to boot (the screen where you select your operating system), move the selector over the OpenSUSE 11.0 option and press the 3 button on your keyboard. When you do this, a 3 should appear at lower-middle section of the boot screen next to the caption: Boot Options. If you don’t have this screen, or doesn’t full understand this, you can login normally, open a terminal window, and login as root with the command su, and your root password. Then issue the command init 3, and you will be brought to the same spot, the CLI (Command Line Terminal). Here, enter your username and password and then issue the command: su to become a SuperUser (root). When prompted, enter your root password, and then once you have root permissions, enter the command: sax2 -r. Sax2 may take some time to load, but it should take less than 20-30 seconds. When it does, check the settings to make sure you have the right resolution and other configuration settings, and then press the OK button and then the Save button once you have set the options to your liking. Now that we are done with the visual configuration, you have to load the X-Server to see your graphical Desktop, in this case, KDE3. To do this, enter the command exit (logs out of root permissions so that you are not logged in as root when the X-Server loads) and then the command startx. This will load your X-Server and should bring you to your desktop. If you still have any issues, feel free to post them. My guess it that the visual problems are worse than they normally are with other driver issues because of the non-standard resolution.

I hope this fixes your problem! :slight_smile:

(PS: Sorry for the length of the post :rolleyes: )

Thank you, I will have to try it later this week. There’s only wireless net at the place where I’m staying and I’ve got a wireless NIC comming in the post, should be here this week. I’ll try it then and then post back for help if needed. Thanks again. =]

No problem. :slight_smile:

I tried using a DVI-D cable instead of a D-Sub and it worked instantly. I guess I won’t be needing those drivers after all.

Thanks for helping =]

Cool. As long as you got it working.

No problem. :slight_smile: