Games on Gnome-installation

In a Gnome-box (leap 15.2), when I try to install some games, e.g.: boswars, dangerdeep, minecraft-launcher, enigma, lincity-ng, zypper tells me it cannot find the packages in question.
On the contrary, in a KDE-Plasma-box I have not any problem installing the same packages.
The games-repository is in both boxes enabled.
And so, I would like to know, whether there is a problem with the configuration of the gnome-box or of the games-repository.

Hi
Can you show the output from your repository configuration for both systems?


zypper lr -dE

 zypper lr -dE
#  | Alias                               | Nom                             | Activé | Vérification GPG | Rafraichir | Priorité | Type   | URI                                                                        | Service
---+-------------------------------------+---------------------------------+--------+------------------+------------+----------+--------+----------------------------------------------------------------------------+--------
 1 | NVIDIA                              | NVIDIA                          | Oui    | (r ) Oui         | Oui        |   99     | NONE   | https://download.nvidia.com/opensuse/leap/15.2                             | 
 4 | beid-release                        | Belgian eID package archive     | Oui    | (r ) Oui         | Oui        |   99     | NONE   | http://files.eid.belgium.be/rpm/opensuse/15.2                              | 
 5 | games                               | games                           | Oui    | (r ) Oui         | Oui        |   85     | NONE   | http://download.opensuse.org/repositories/games:/tools/openSUSE_Leap_15.2/ | 
 6 | http-download.opensuse.org-2412a270 | openSUSE:Leap:15.2:Update       | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/oss/                         | 
 7 | openSUSE-Leap-15.2-1                | openSUSE-Leap-15.2-1            | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/              | 
 8 | packman                             | packman                         | Oui    | (r ) Oui         | Oui        |   90     | NONE   | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.2/         | 
13 | repo-non-oss                        | Dépôt Non-OSS                   | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/          | 
14 | repo-oss                            | Dépôt principal                 | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/              | 
17 | repo-update                         | Dépôt principal de mise à jour  | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/oss                          | 
18 | repo-update-non-oss                 | Dépôt de mises à jour (Non-OSS) | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/                     | 

I am nw running the gnome-box on my laptop and so do not have the output for the plasma-box

Hi
Sure it’s the tools sub repository? Likely you have this one on the other system (as that’s where the packages are) <http://download.opensuse.org/repositories/games/openSUSE_Leap_15.2/&gt;

Yes, I am sure.
By the way, some years ago I already was confrontated with the same problem, everything OK on KDE and some little troubles on Gnome (also with games).
Hereunder you can read the configuration of my games.repo

[games]
enabled=1
autorefresh=1
baseurl=http://download.opensuse.org/repositories/games:/tools/openSUSE_Leap_15.2/
priority=85
keeppackages=0

And here is the output of neofetch:

neofetch 
           .;ldkO0000Okdl;.              thibaud@gwerlas 
       .;d00xl:^''''''^:ok00d;.          --------------- 
     .d00l'                'o00d.        OS: openSUSE Leap 15.2 x86_64 
   .d0Kd'  Okxol:;,.          :O0d.      Host: Aspire E5-774G V1.23 
  .OKKKK0kOKKKKKKKKKKOxo:,      lKO.     Kernel: 5.3.18-lp152.44-default 
 ,0KKKKKKKKKKKKKKKK0P^,,,^dx:    ;00,    Uptime: 1 hour, 25 mins 
.OKKKKKKKKKKKKKKKKk'.oOPPb.'0k.   cKO.   Packages: 2620 (rpm) 
:KKKKKKKKKKKKKKKKK: kKx..dd lKd   'OK:   Shell: bash 4.4.23 
dKKKKKKKKKKKOx0KKKd ^0KKKO' kKKc   dKd   Resolution: 1920x1080 
dKKKKKKKKKKKK;.;oOKx,..^..;kKKK0.  dKd   DE: GNOME 3.34.5 
:KKKKKKKKKKKK0o;...^cdxxOK0O/^^'  .0K:   WM: GNOME Shell 
 kKKKKKKKKKKKKKKK0x;,,......,;od  lKk    WM Theme: Adwaita 
 '0KKKKKKKKKKKKKKKKKKKKK00KKOo^  c00'    Theme: Adwaita [GTK2/3] 
  'kKKKOxddxkOO00000Okxoc;''   .dKk'     Icons: Adwaita [GTK2/3] 
    l0Ko.                    .c00l'      Terminal: gnome-terminal 
     'l0Kk:.              .;xK0l'        CPU: Intel i7-7500U (4) @ 3.500GHz 
        'lkK0xl:;,,,,;:ldO0kl'           GPU: Intel HD Graphics 620 
            '^:ldxkkkkxdl:^'             GPU: NVIDIA GeForce GTX 950M 
                                         Memory: 2063MiB / 11841MiB 

                                                                 


Hi
The games:tools repository is not the place for the missing packages, they are in games only, you need to fix the link :wink:

For example minecraft-launcher;
<http://download.opensuse.org/repositories/games/openSUSE_Leap_15.2/x86_64/minecraft-launcher-2.1.17627-lp152.1.1.x86_64.rpm.mirrorlist&gt;

No games:tools, just games.

Thanks a lot, it is working now :slight_smile:

Hi
Good deal, enjoy :slight_smile:

PS: You might be interested in <Welcome - openSUSE Build Service; https://multimc.org/

I will certainly show it to my son, he is fond of minecraft!

Hi
Likewise here :slight_smile: The other one is minecraft-overviewer… <Welcome - openSUSE Build Service; http://overviewer.org/

I don’t have much experience of using Gnome but if it can’t even install a game properly its not worth much anyway.