Games crashing after Nvidia Driver update

Hey, I just started using OpenSUSE a couple weeks ago and I’m loving it so far, but I’ve been getting strange issues with games after installing the Nvidia drivers with the one-click install found here I have a GTX 650 Ti and am running OpenSUSE 13.1. The problems with the games is never consistent though, which makes it hard to troubleshoot through Google.
The game Faster Than Light ran perfectly before I updated my driver, me being able to play for hours at a time. Now, the game will last about a minute before my computer locks up and just freezes without an error message.
Something similar happened with Wasteland 2, but it takes about five minutes for the game to lock up on me.
Tales of Maj’Eyal is extremely choppy to the point where it’s unplayable.
Hotline Miami, however, runs perfectly fine and I ran into no issues whatsoever.
I’m new to this whole Linux thing, and I would greatly appreciate any help at all. If it helps at all, I was able to play all these games fine on Windows 7. If I’m missing any vital information, please let me know.

Open Yast - Software management search for NVIDIA be sure that the installed packages are

  1. for the correct kernel should be desktop unless you changed it
  2. all the same GOX version should be GO3 for you

you should have


If you don’t have these correct them

Thanks for the quick response. I double checked all of these, but the problem is still there. If it helps at all, after I installed the driver for the first time, it booted to a super low resolution. It changed back to normal after another reboot though.

If you have those pcakages and only those NVIDIA packages that should be OK

The newest driver seems to require a second reboot

Don’t know why you games have problems. What source are those games?

Running under wine or something else??

The games all have native Linux versions. Everyone but Tales of Maj’Eyal I’m playing through Steam. Tried rebooting again, but no dice.

You could try the latest stable Nvidia driver from here :

It does note in the bug fix log

  • Fixed a bug that could cause OpenGL programs to freeze under some low memory conditions.

Or if you want the latest beta driver you can find it here:

These do of course require the driver to installed “The Hard Way”

Make sure you follow the instructions for your version of opensuse, ie
On openSUSE >= 12.2

Oh and uninstall your current Nvidia binary drivers first.

How exactly do I go about this?

Assuming you installed via Yast or one click go to yast - software Management and search for NVIDIA and uninstall the packages with NVIDIA in the name.

To install the hard way you will need to install kernel source package and gcc compiler. down load from NVIDA site and mark the file executable then run it

Alright, I installed them the hard way and disabled the Nouveau driver, but my games are still crashing. Could a fresh install remedy the problem?

I doubt it unless you truly messed things up and installed a bunch of thing from odd repos like factory

Maybe simply not enough memory. Or some flaky hardware that does not like to be driven hard.

I had a fan go out on my old 6800+ card and it ran ok until I put a load on it and the temp went north of 100 C Then boom crash.

So check your cooling.

The nvidia-setting program has a good temp indicator in it.

My temps are normal, or at least are the same as they were on Windows.
This is what I get when I search Nvidia, I’m pretty sure I followed the steps exactly but I could have screwed up somewhere.

Hmm lets take this from the top again.

1 ) So you have only had opensuse for a couple of weeks, the last update to the Nvidia driver (in the Nvidia repo) was 6th june (build date) - what were you using before this ? Were you using the
open source nouveau drivers first then installed the nvidia proprietry.

  1. the only game crashing observed is from Steam, Tales of Maj’Eyal just runs choppy

Ok lets check a couple of things:

  1. Open the nvidia settings panel and check page flipping is off - this did cause choppy performance for me on a GTX 750

  2. Install Mesa-demo-x in yast. Open a terminal and type this command: glxgears. Please post your reported frame rate here. Next type this command: glxinfo and report the output here. NB please use code tags when when pasting the output information - see here for info

  3. Did you install the steam client from the repos (Games:tools) - I’m thinking the crashes may be related to steam.

4 ) It’s a long shot and probably grasping at straws but if you go to system settings > Desktop effects > Advanced and check that compositing type is set to opengl 3.1 and Qt graphics system is
set to raster. - this is assuming of course you are using KDE.

5 ) Are your video card fans clean ?

I assume I was using Nouveau before, I didn’t mess with the drivers or settings at all. All my crashes happened after using the 1 click install for Nvidia drivers. The only game I played before installing them was FTL, and I was able to play it for hours at a time.
Flipping was on, and my composition type was set to 2.0 native. After changing these though, I still experienced a crash twice with Wasteland. I did install Steam through the repo, and I’m gonna try running some non-Steam games as soon as I can to see if it is the problem. I also had a similar crash to what I’ve been having games while just on my desktop(screen freezing, music stopping a few seconds after the freeze). Wasn’t doing anything resource intensive, just using Banshee and using Steam’s chat client.
Glxgears results, continued for a long time with similar results.

Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
303 frames in 5.0 seconds = 60.459 FPS
301 frames in 5.0 seconds = 60.024 FPS
301 frames in 5.0 seconds = 60.021 FPS
301 frames in 5.0 seconds = 60.017 FPS
301 frames in 5.0 seconds = 60.025 FPS
301 frames in 5.0 seconds = 60.022 FPS
301 frames in 5.0 seconds = 60.018 FPS
301 frames in 5.0 seconds = 60.018 FPS
301 frames in 5.0 seconds = 60.022 FPS
301 frames in 5.0 seconds = 60.022 FPS

Glxinfo results were too large for a post, so I just dumped them in a pastebin

Well everything seems ok there, you are running nvidia 337.25 the hard way and it’s all installed OK.

Are you using Nvidia HDMI audio or your soundcard ?