games appear partly on 2 screens with twinview

I configured my dual monitor setup with twinview.
Problem is that 3D games I want to play that half of the game show on one screen, and the other half on the second.

I want to appear the game on one monitor only without disabling the other monitor.

When I close the game I want to be able to use both screens again?

Does someone know a solution?

I know this link to the Gentoo twinview wiki, but if I try that and restart one monitor keeps being disabled.

I’m afraid that the ‘fullscreen on one’ and other off is pretty much the way it works with twinview. You CAN disable twinview and set up dual-head and xinerama, but that’s no fun really.

What I found as a good solution was to choose windowed mode and set the window size to 1440x900 (or a smidgen smaller), and position it on the screen using ‘ALT+mouse move’ to make the window decorations go away (or you can set some stuff to make that app not ever have decorations).

Several games I play (warzone2100 and others) allow me to specify an exact window size, so 1434x850 fits on the screen nicely and leaves the dock/taskbar visible.

You’ll have to play with it really. Xinerama would allow you to do what you want, but it has things about it I didn’t like, and twinview was so much nicer anyways. Your choice.

Take Care,

Lornix
lornix@lornix.com

I keep on experimenting with it. I don’t mind that one screen is turned of while playing a game, but before and after playing it I want both screens to be active without messing around in the nvidia settings to make it do so.

sonics73 wrote:

>
> I keep on experimenting with it. I don’t mind that one screen is turned
> of while playing a game, but before and after playing it I want both
> screens to be active without messing around in the nvidia settings to
> make it do so.
>
>
I added a MetaModes option line to xorg.conf (/etc/X11/xorg.conf) to allow
the x-server to turn off second monitor if needed:

Section “Screen”
Identifier “Screen[0]”
Device “Device[0]”
Monitor “Monitor[0]”
DefaultDepth 24
Option “TwinView” “True”

magic is here: put modes as “monitor1,monitor2; etc,etc;” so here you can

see that I’ve got 1440x900 on both, then 1440x900 on [1] and [2] is off…

and so on.

stupid line wrap! [jedi handwave] the line break isn’t there [/jedi]

Option “MetaModes” “1440x900,1440x900; 1440x900,NULL;
1024x768,NULL; 800x600,NULL; 640x480,NULL;”

Option “TwinViewOrientation” “RightOf”

“Display” subsections go here

EndSection


L R Nix
lornix@lornix.com

thanks, I solved it.

My xorg.conf was made messy by nvidia-setting so I rewrote it according to examples on the net. My final one is:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "P17-2"
    HorizSync       31.0 - 82.0
    VertRefresh     50.0 - 76.0
EndSection



Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7600 GT"
    Option     "RenderAccel"
    Option     "HWcursor"
    Option     "CursorShadow"
    Option     "CursorShadowAlpha" "32"
    Option     "CursorShadowXOffset" "3"
    Option     "CursorShadowYOffset" "3"
    Option "AddARGBGLXVisuals" "true"

EndSection



Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option      "TwinViewXineramaInfoOrder" "DFP"
    Option "SecondMonitorVendorName" "unknown"
    Option "SecondMonitorModelName" "LG L1750SQ"
    Option "SecondMonitorHorizSync" "30-83"
    Option "SecondMonitorVertRefresh" "56-75"
    Option "TwinViewOrientation"      "Leftof"
    Option         "metamodes" "DFP: 1280x1024, CRT: 1280x1024; DFP: 1280x1024, CRT: NULL; DFP: 1024x768, CRT: NULL; DFP: 800x600, CRT: NULL; DFP: 640x480, CRT: NULL;"
EndSection

Section "Extensions"
    Option         "Composite" "on"
EndSection

sonics73 wrote:

>
> thanks, I solved it.
>
> My xorg.conf was made messy by nvidia-setting so I rewrote it according
> to examples on the net. My final one is:
>
>
> Code:
> --------------------
> Section “Monitor”
> Identifier “Monitor0”
> VendorName “Unknown”
> ModelName “P17-2”
> HorizSync 31.0 - 82.0
> VertRefresh 50.0 - 76.0
> EndSection
>
>
>
> Section “Device”
> Identifier “Videocard0”
> Driver “nvidia”
> VendorName “NVIDIA Corporation”
> BoardName “GeForce 7600 GT”
> Option “RenderAccel”
> Option “HWcursor”
> Option “CursorShadow”
> Option “CursorShadowAlpha” “32”
> Option “CursorShadowXOffset” “3”
> Option “CursorShadowYOffset” “3”
> Option “AddARGBGLXVisuals” “true”
>
> EndSection
>
>
>
> Section “Screen”
> Identifier “Screen0”
> Device “Videocard0”
> Monitor “Monitor0”
> DefaultDepth 24
> Option “TwinView” “1”
> Option “TwinViewXineramaInfoOrder” “DFP”
> Option “SecondMonitorVendorName” “unknown”
> Option “SecondMonitorModelName” “LG L1750SQ”
> Option “SecondMonitorHorizSync” “30-83”
> Option “SecondMonitorVertRefresh” “56-75”
> Option “TwinViewOrientation” “Leftof”
> Option “metamodes” “DFP: 1280x1024, CRT: 1280x1024; DFP:
> 1280x1024, CRT: NULL; DFP: 1024x768, CRT: NULL; DFP: 800x600, CRT: NULL;
> DFP: 640x480, CRT: NULL;” EndSection
>
> Section “Extensions”
> Option “Composite” “on”
> EndSection
> --------------------
>
>

Congrats. Enjoy!


L R Nix
lornix@lornix.com