G4 PPC MBR woes when installing OpenSuSE 10.2

Good morning,

Been plugging away for a few days now, hopefully someone can help. I’m trying to install OpenSuSE 10.2 (only have CD access) on a Mac G4 PPC arch. The install goes well until reboot time. The system does not reboot as the boot loader does not exist or unable to be found. I have tried using the rescue > boot loader option to edit/format/re-configure to have it boot from MBR. System comes back with an error - unable to intiate. I have tried using the fdisk - unable to change MAC labelled disk. I have tried partd, able to delete all partitions other than the primary MAC partition. In summary, I donot appear to be able to delete/remove/overwrite the MAC MBR. Any suggestions would be helpful?

this may help Linux.com :: Installing SUSE Linux 10.1 on a PowerPC Mac i know it’s for 10.1,but, it may give you some ideas.BTW, i don’t use/have a MAC

Andy

What you will need to do, is to create a small partition, say 20MB, at the start of the disk. Don’t format it. but set it’s type to HFS.

Then partition the rest of the disk, as you like.

I just installed opensuse 11.0 on my powerbook G4 last night. I don’t know about opensuse 10.2. But in my case, I just used the default selection of packages to get the system up and running. I ran into a few problems, the install would fail, when choosing some extra packages (i.e. compilers, kernel src, etc).

Thanks - tried that as well, configured a small 33MB HFS partition, a 1.3GB swap and 71GB root partition. Defined the small HFS partition to be the boot install partition at installation time and re-installed OS. Reboot - nothing. Tried the alt ket - does not find any bootable partitions on drive. Nothing!

Has the installer been able to write the bootloader into this first 30 MB partition? Can happen that this doesn’t work. You might find more hints here installing openSUSE 11 PPC on a PowerBook G4. Especially look for this PPC Partitioning. I had the same problem and was able to solve it with this.

Define the 30 MB partition to nothing and the big one to boot. As only the bootloader goes to the 30 MB.

What I wanted to say is, no mountpoint for the Apple_HFS only the bootloader will be installed here. The main partition holds the system.

Finally - happiness - thanks for all the help!

Curiously it turns out that although I am not dual booting, I needed 2 “small” HFS partitions. I was not able to name the first HFS partition “boot” so I created a second which I could name “boot”. Once that was done the installation went well and the bootloader was installed and everything is working.
So I now have …

  • Apple_HFS partition map
  • Apple_HFS “untitled” 128MB partition
  • Apple_HFS “boot” 32MB partition
  • Linux “swap” 1.3GB partition
  • Linux “root” 72GB partition

Nice to be up and running:)