FYI - Virtualbox 6.0 Guests

Applies to openSUSE LEAP 15.0 and 15.1 Guests running Virtualbox 6.0 running on Windows (Last I heard, do not know if anything has changed about issues installing VBox 6.0 on openSUSE as the HostOS). Assume that running TW as a VBox Guest is not different than LEAP.

VBox users should know that VBox 6.0 is a major upgrade with new features and slightly different configurations compared to earlier VBox versions.

A good starting point is the current Virtualbox Guest Additions documentation

A few highlights I notice…

  • I seem to remember shared folders automatically mounted in the same place as the optical disk (or was that my imagination?). Auto mounted folders are now located in
  • A special (proprietary?) USB driver that is separate from Extensions is installed
  • Extensive new support for 2D and 3D hardware acceleration, but mostly for Windows Guests (Unsaid in the documentation if these new capabilities are possible on non-Windows HostOS)
  • I haven’t had the opportunity to try “Seamless Windows” but it looks interesting and that may be related to a new way of file sharing between the Guest and Host, no longer requiring setting up Shared Folders there is a new Virtualbox File manager which is much like Midnight Commander or the old Konqueror File Manager enabling files to be transferred between any file location in the Guest and any location on the HostOS.
  • Some general management functions like snapshot management and the main buttons for Run, Stop, Settings and New have been re-located to more efficiently use display space.
  • Some new overcommit capabilities commonly found elsewhere. Virtualbox claims the way it does memory page sharing is more efficient and less resource intensive. Could mean more virtual machines running simultaneously.

Some of the “new” features like Guest Properties look like a re-packaging of VBoxManage APIs. May look more closely sometime to see if there is indeed anything really new.

Some adventures in Guest Additions…
I found that for 15.0, the existing Vbox 5.2.2 extensions sort of worked when the Guest was first opened after upgrading to 6.0. But you could see something was likely wrong like jittery graphic movements. Configured Shared Folders worked and auto display re-sizing worked.

My first attempt to upgrade Guest additions in this 15.0 Guest was to build using the Guest Additions ISO. The Guest Additions ISO failed to build and wrecked existing installed Guest Additions… I would suggest being wary if you try to install Guest Additions from the VBox application. But! – The pre-built Guest Additions from openSUSE work just fine!

So, bottom line for openSUSE 15.0 Guests, I recommend upgrading Guest Additions by simply doing a forced re-install of the pre-built Guest Additions as follows, and if you did a mis-step like I did, can fix those problems too

zypper in -f virtualbox-guest-tools virtualbox-guest-x11

On the other hand, with openSUSE 15.1 so far (I’ve only run a few tests up to now),
Although Guest Additions should install automatically in most cases during the install due to the install detecting being installed in a virtual machine, a Guest I created running only the awesome WM did not install Guest Additions. I then attempted to install the openSUSE Additions from openSUSE, but although the installations did not error, there was no functionality. I then uninstalled the Additions packages and installed using the VBox app’s ISO file, and that worked perfectly, the virtual machine has full Additions functionality including display re-sizing, seamless mouse between Host and Guest. Shared folders does not work right away, but that is likely because of an idiosyncrasy of awesome that there is no /media/ folder by default so automounting likely failed when the parent folder doesn’t exist.

As Virtualbox 6.0 is used more, I’m sure that more new features will be discovered.

Probably not specific to VBox 6.0, I now see a libvirt Virtualbox daemon package in the OSS, and online documentation verifies that Virtualbox can now be managed using libvirt if you prefer over Virtualbox’s own virtual machine manager. Can Virtualbox have dreams of being used as an Enterprise solution instead of only as a personal solution?


I have just been through installing VirtualBox 6 Guest Additions myself - and eventually succeeded. But it costed me several hours. Pain.
I posted my notes here:
Initially it was meant to be an answer to your post but it grew enough to deserve it’s own wiki page.
It can be considered as updated version of your post, reflecting current state of things as of 2019-09-23.
I also made few different observations.
My main goal were to have “Shared Folder” and “Auto-resize Guest Display”.

I also investigated on differences between Oracle Guests Addition ISO and openSuse packages like virtualbox-guest-kmp-default, virtualbox-guest-tools, virtualbox-guest-x11 which seems to provide the same thing. Well, I found the answer.

I also tried to install Oracle’s Virtual Box from their openSuse repo - and failed.

I also tried to use “Insert Guest CD Image” with automated download - an failed.

I had to do it manually and here I finally succeed - by:

  • REMOVING virtualbox-guest-kmp-default, virtualbox-guest-tools, virtualbox-guest-x11 packages
  • installing only virtualbox-guest-source package
  • downloading Guest Addition ISO manually and thenVirtualBox GUIDevicesOptical DrivesChoose disk image.
  • and finally running the installation script from (auto) mounted Guest Addition ISO

> Extensive new support for 2D and 3D hardware acceleration, but mostly for Windows Guests (Unsaid in the documentation if these new capabilities are possible on non-Windows HostOS)

I suspect this is provided by VirtualBox Host Additions. Yet another set of additions. Also not provided by openSuse.
I installed them too, they go to the host system. I did it because I wanted play with VBox “Disk Encryption” (to encrypt the whole VM).
But I also noticed it enabled several options in Display area.

Fixed URL:

Thanks I had gone to vbox site and all i could find was vbox 6.0.12beta and it would work. At least not the way i figured it would work. All I could get was a broken download as you reported. now i got guest additions saved but can’t install cause the vm crashes as soon as it starts to run. My problems are just beginning I suspect.

I have vbox from opensuse on a 15.1 host as vbox 6.0.12 and have vm’s for windows xp and windows 7, linux opensuse vm’s of 11.2 and 13.1 and the next vm I am trying to create is for a Raspberry Pi 3 emulation so I can test stuff targeted at that ubuntu based debian system. It loads no problem then it does reboot and crashes with system error system halted. All the previously installed vm’s run ok but with older guest additions.