fx 5200

Is there something special I am supposed to do after installing the proprietary driver for this card from the Nvidia repo with Yast in 11.3?

After installing it and rebooting I got a message saying something like the drivers abi was not supported by the server, but the driver available for download on the nvidia site says it supports this card on x server 1.7.

It’s a low profile 4x card.

I can go back and reinstall the driver and check the message more thoroughly if you need more information.

Thanks

So it looks like that the nVidia driver version 173.14.25 for your FX 5200 video card requires a legacy nVidia driver which is updated for X.Org X Server 1.7.0 however openSUSE 11.3 is using X.Org X Server 1.8.0 as I am able to find. It would seem that until such time as the legacy driver gets updated for X.Org 1.8, you may have to continue using openSUSE 11.2 or consider upgrading your video card, if possible.

Thank You,

Wow! That sucks… Is Ubuntu 10.04 using an older X server version than openSUSE 11.3? The card works fine in there with the proprietary driver and I just realized I could load 11.3 up on this mini pc here that has less that a gig of memory with a web install, and pulled 10.04 out of it to do it.

Aargh.

This is what the error message said:

This server has a video driver ABI of 7.0 that is not supported by this nvidia driver. Please check Welcome to NVIDIA - World Leader in Visual Computing Technologies for a driver updates or downgrade to an X server with a supported ABI.

Scott_Swinyard this issue does kind of suck. I wish I had better news for you. I even had one of those cards (it was agp as I remember) many moons ago in a desktop, but I have moved on. Do consider that openSUSE 11.2 will continue to be supported for many more months. I would say though you got to consider doing an upgrade. nVidia is still a good choice but it would seem they are pushing the edge for support on the other end of the spectrum with the 300 and 400 series video cards. My best video card is a GT 275 which worked without issue in openSUSE 11.3 which I recommend though it takes up two card slots and needs two power supply plugs to use.

Thank You,

I understand what you’re saying but I can’t move on. I don’t have the money. My main computer has an Ati 9500 pro in it which sticks me at 11.0 because it’s limited to fglrx 9.3 and for some reason 3d games don’t work well in 11.1. I’ll probably have it for at least a couple more years.

This little computer with the nvidia I found discarded and is one of those little Compaq Evos that sits on the desktop and has a mini low profile agp card in it. It only had a Tnt Vanta originally but I upgraded that to the 5200 for $25.00.

I was only using it because my main pc is out of commission at the moment

I"m not going anywhere anytime soon. I was just surprised that it ran in Ubuntu but not in openSUSE.

I don’t like to be preferential, but I’ve been using OpenSuse by whatever name since early 2006 starting with 10.0. That was my first real Linux Distro and I have to say it’s my favorite to this day. I tried out Pclinux OS which was very nice a couple years ago, and then 10.04 on this mini pc here but some how openSUSE seems to have something they just don’t, and I can tell that just by being back in here for the last couple hours.

Have you noticed how it has shot up in the Distrowatch rankings since 11.3 came out?

Thanks again for trying to help.

Its not as bad as you may think.

I used to startx (during the milestone releases of 11.3) by booting to run level 3, and then login as a regular user and type:

startx -- -ignoreABI

which would work for me. Of course before doing that I had to also blacklist the nouveau driver in the /etc/modprobe.d/50-blacklist.conf and go to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”.

nVidia are actively working to update their proprietary driver, and there is a beta version of their new driver (which I installed last night on my nVidia FX5200 fitted PC) referenced here: 173.14.27 (legacy prerelease) for Linux x86/x86_64 released - nV News Forums

With this new driver version, one does NOT need to use that custom ‘startx – -ignoreABI’ command. I suspect one also does not need to add their regular user to group audio to overcome the audio permissions problem introduced by the older driver (although I have not tested that yet).

When ever I look for an updated nVidia driver, I always find it useful to check the nVidia forum, and here is the link to their stickie on Linux driver versions: Current NVIDIA Linux graphics driver releases - nV News Forums

Oldcpu, thank you. there was a message with the error that mentioned ignoring the abi, but I read it as meaning simply not to show the message anymore, not that then the driver would work.

I’ll look into all the pieces of information you gave me and let you know what happens.

Many thanks Oldcpu. I’ve been struggling with my wife’s pc, which has said FX5200 card, for days and had come to the conclusion that there was some problem with the compatibility of this card. Your solution, although not ideal, does the trick. I look forward to Nvidia’s upgrade in the near (hopefully) future.

On a positive note though I really love this latest openSUSE offering… very slick. I am using KDE version which has to be THE best yet from any distro :slight_smile:

Many thanks Oldcpu. I’ve been struggling with my wife’s pc, which has said FX5200 card, for days and had come to the conclusion that there was some problem with the compatibility of this card (my pc has a much newer Nvidia card and I had no problems). Your solution, although not ideal, does the trick. I look forward to Nvidia’s upgrade in the near (hopefully) future.

On a positive note though I really love this latest openSUSE offering… very slick. I am using KDE version which has to be THE best yet from any distro :slight_smile: And for the first time in a long time my Maudio card works out of the box (no killing puseaudio etc) :smiley:

Glad that works. When I installed the 173.14.25 driver, to get sound to work on openSUSE-11.3 I also had to add my regular user to group audio. And I had to shutdown with the terminal command ‘shutdown -h now’ .

With the pre-release (beta) 173.14.27 driver I did not have to do that. … The 173.14.27 driver is working well for me thus far on openSUSE-11.3.

Well…No luck.

I couldn’t try the ignore-abi switch because I didn’t know how to apply it especially with no xorg.conf. Based on what I’ve read so far on these forums it appears the chances of that having worked are actually rather small. None of the other methods mentioned so far helped so I installed the beta driver you told me about oldcpu, but my monitor came up out of range and the screen was garbled.

I’m at a dead end based on what I know unless you know the solution.

I must admit that was on my own pc and not my wife’s. So whereas I’m happy out of the box, my wife’s pc, usually old but stable, for once is being the rascal!!! Still we’re getting there, I wish I had the ability to provide good help as you do… My main help for openSUSE is to seriously recommend it and install it on friends and families computers and act as a knowledge base until they are confident in their own abilities… but I’m moving off subject… except I’m not really… that’s what Linux is about… We are a community dedicated to improving the computing experience…

I need to know if you applied all the things that need to be applied when you applied the beta driver. Did you

(1) black list the nouveau driver in the /etc/modprobe.d/50-blacklist.conf file ?

(2) Did you either boot with the ‘nomodeset’ parameter or change the setting in YaST with : yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. If you did those, then there are things we can try to get the proprietary driver working …

In essence what I will be doing is following this guide: SDB:Configuring graphics cards - openSUSE

Hmmm … seems another user may have encountered this … in part this could be a hardware issue with your monitor. Please read this (post #3) : After setting nomodeset Cannot reboot system

Do you have a spare monitor you can use briefly ?

If not, there may be another edit you can do …

Possibly the advice in post#7 here might also help: (http://forums.opensuse.org/english/get-help-here/hardware/442615-i-cant-change-screen-resolution-suse-11-3-a.html#post2195087)
… you may need to do the edit from run level 3.

I’ve been through this with the 5200 in my laptop (which worked fine with 11.2). -ignoreABI (or the equivalent setting in xorg.conf) doesn’t work. You do get the NVIDIA splash screen when doing that, so you know the right driver is loaded, but then you just have a black screen.

I have NO_KMS_IN_INITRD set correctly, and I’ve tried blacklisting both nouveau and nv from the kernel boot prompt, and also tried “nomodeset” from the kernel boot prompt. I’m pretty sure the ABI in xorg 1.8 simply isn’t compatible with this old driver.

The command is not “-ignoreABI”. It also NEVER worked for me in the xorg.conf.

Rather the command is:

startx -- -ignoreABI

The slightest syntax error in that command and it will NOT work.

Plus for my FX5200 it was ESSENTIAL to BOTH blacklist the nouveau driver in /etc/modprobe.d/50-blacklist.conf AND also ESSENTIAL to change in YaST yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”.

Both of those had to be done BEFORE building the proprietary driver the hardway.

IMHO the ‘blackscreen’ could be a symptom of the nouveau driver NOT being blacklisted properly. After such a black screen, if you can not get to a text log in, then you really should then reboot to run level 3 (do NOT run graphics in the reboot) and then check the contents of the previous .xsession-errors file and also check the contents of the /var/log/Xorg.0.log file. Else everything is just wild speculation and not very helpful to seeing why it did not work.

I looked in Yast and there appeared to be an Nvidia driver with a newer build date than the one I was trying before, so with all the system settings at default I installed it and rebooted.
The My Computer window in Kde shows this now:

Vendor: nVidia Corporation
Model: GeForce FX 5200
2D driver: nvidia
3D driver: NVIDIA 173.14.27

It seems to be working properly as far as I can tell and the 3d effects on the desktop are working but the maximum resolution available is 640x480.

Does anybody know what is causing this?

Nobody knows why I have a fully functional driver but limited resolutions?

Nothing I’ve read anywhere so far tells my why this particular thing is happening and I don’t want to touch anything until I know more since I don’t know what I’m doing and don’t want to bullocks it up.

Any information you need I will gladly supply.

Reference more information, please copy the content of EACH of the files I am going to recommend to a separate upload/page on Pastebin.com (pressing submit in each case). That will give you a URL/webpage-address for each. Post those web page URLs here so that we can examine the content of those files. The files are:

  • /var/log/Xorg.0.log
  • /home/your-username/.xsession-errors
  • /var/log/boot.msg

Please also confirm you have no /etc/X11/xorg.conf file.