Future of Bumblebee project?

Hello,

I’ve recently installed the lastest build of Tumbleweed on an external SSD and I was surprised to find out that the all bumblebee functions work. I used my own “easy way” with the changes to repositories to tumbleweed instead of LEAP 15.1 (https://forums.opensuse.org/showthread.php/537906-Cuda-Nvidia-bumblebee-codecs-quot-safe-quot-way).

I’ve been hesitating to upgrade my work laptop with Nvidia dGPU from LEAP 15.1 to LEAP 15.2 because of my “dreaded” change to suse-prime from bumblebee.

I remember from the last development discussion that Bumblebee will no longer be supported and that no one is assigned to it and suse-prime will be practically replacing bumblebee from LEAP 15.2 and on. Is this true? I will test it out on my external SSD at some point but I’m very curious.

What is the future of the Bumblebee for OpenSUSE?

Hi
It could be improvements in the Leap release and kernel? It’s not built for Leap 15.2 in the devel project and failing to build…

It is in the Leap 15.2 Release, so I don’t see why you can’t use it, if it breaks going forward, then getting it fixed may be an issue. Why not do a test install to see how prime goes? If you have issues, help improve and create a bug report?

I have seen reports and heard that the entire bumblebee module is missing entirely in Kernel 5.+ for LEAP 15.1 and 15.2 but I will find out sooner or later. I will also check out prime eventually but what I’m most worried is the display forwarding through i/d GPU.

In my older Lenovo laptops (T420, T430, W530) VGA port passes through iGPU and Display port through dGPU and the only way to be able to both work is by using Bumblebee. If I used Intel driver only, only VGA port worked, if I used Nvidia only, only DP worked.

I am not sure what the configuration is for my current Lenovo T480 but I have a funny feeling that I’ll run into similar/same issue when I start using prime.

For the time being, is there no one working on bumblebee at all? I guess eventually it won’t work on Tumbleweed either.

Despite everything, the following seem to be true: <https://software.opensuse.org/package/bumblebee&gt;

That is so weird. I literally have the latest TW build with bumblebee working.

ILL you are using old build, newer fails, possibly due to update of gcc.

I just updated my TW (2020-07-28 1800 UTC) by dup. I had to reconfigure /etc/modprobe/50-bbswitch.conf load state but everything works on my Optimus laptop.

Is the standard TW repository pointing the the old build of bumblebee? I hope it stays that way.

You may save needed files at your local drive.

I am not quite sure how I can do that for the packages that has already been installed, any suggestions?

Direct download: https://software.opensuse.org/download/package?package=bumblebee&project=openSUSE%3AFactory

And https://software.opensuse.org/package/nvidia-bumblebeehttps://software.opensuse.org/package/bumblebee-amd

TW Kernel 5.8 doesn’t seem to support bumblebee for the time being. I am going to stick with 5.7.1 and test prime in 5.8

Acutally TW’s 5.8.0.1 seems to be just not compatible with repository’s nvidia-gfxG05 for the time being.

On Lenovo T480 with NVIDIA MX150 dGPU,
bumblebee is working on LEAP 15.2 kernel 5.3.18-lp152.36-default with nvidia-gfxG05

This is a pleasant surprise for me