fuppes xbox 360 streaming media from linux opensuse 11.1

i am aggrivated. had problems with compiling fuppes[http://fuppes.ulrich-voelkel.de/download/](a upnp media sharing server), went to opensuse search 1 click installs area and installed automake, subversion(to dl a new svn copy), gcc-c++[search for gcc-c], libtool, sqlite3-devel, libxml2-devel, gettext-tools, pcre-devel, ffmpeg
went here → <http://fuppes.ulrich-voelkel.de/wiki/index.php?title=Compiling_on_Linux#Suse_11.1>
said to change the fuppes/src/plugins/ffmpeg/ffmpeg.cpp
on line 2272 to take out the (PixelFormat)'s out of the first line in front the zeros and into the second line in between the zeroes. said to ./configure --enable-video-transcoding --enable-gnome-panel-applet --enable-libnotify --prefix=/usr
make and make install
i had a prompt with no errors that i saw on the bottom anyway after the make and no errors with a make install
i ran fuppes had no vfolders.cfg copied and pasted 5 lines off of here → <http://fuppes.ulrich-voelkel.de/wiki/index.php?title=Virtual_folder_configuration> and made it my /root/.fuppes/vfolder.cfg … somehow i am missing my vfolder.cfg and fuppes.cfg that were in /root/.fuppes/ … what is a good vfolder.cfg and fuppes.cfg configuration? i also have twolame on there but it doesn’t say that when i do the web interface thing with it. was looking for example confs, possibly a rpm for fuppes? how to get it to recognize the 360 or the 360 to recognize the pc. firewall exception is set on the yast&users+security&Firewall&Allowed&Advanced tab with the port having to set it everytime i run the program. tried opening the ports on the router too, everytime. cant get the 360 to detect the pc. ushare doesn’t have transcoding for my divx movies and mythtv is a mofo to set up. plus i dont have a tv card. just making sure, is /root/.fuppes/ the directory with the vfolder.cfg and fuppes.cfg? im pretty sure it WAS.

  1. how can i get the 360 to detect the pc
  2. is /root/.fuppes/ the right dir
  3. if upnp is enabled on router do i need to set a port open
  4. is it because i dont have all the codecs?

athlon 64 x2 6000+
geforce 8600 gt
fully updated suse(kernel-<–

ps i think this was an old method to connect to xbox 360 before the green makeover

i went here it said to edit the .cfg’s<http://fuppes.ulrich-voelkel.de/wiki/index.php?title=Microsoft_Xbox_360> but its still not detecting the xbox

i just gave up… fuppes wouldn’t detect the xbox.i came to the conclusion that fuppes was for the old setup of the 360, not the green makeover. xbmc at sourceforge mentioned a upnp av service so i got that(up to date 300 meg packages, a 100meg package and a 97meg package.http://sourceforge.net/projects/xbmc/files/XBMC%20Live/XBMC_Live-9.04.1.zip)now i download xbmc media center 100meg [package]Browse XBMC Media Center Files on SourceForge.net](http://sourceforge.net/projects/xbmc/files/) and proceed to find small lib -devels on opensuse.org, pbone.net, and packman-links2linux.org. they are so far… [use start+computer+install software]
gcc-c++ search on opensuse.org “gcc-c”
boost-devel best downloaded off opensuse.org with the yast 1 click
glew-devel, libmad-devel, libjpeg-devel, libogg-devel, libvorbis-devel, libbz2-devel, sqlite3-devel, libmysqlclient-devel, libpng-devel, pcre-devel, lzo-devel, libcdio-devel,
libSDL_image-devel, libSDL_mixer-devel, libjasper-devel, libcurl-devel, libdbus-1-qt3-0-devel(since i cant find libdbus-1-devel by itself and libdbus-1 is an installed dependency when you are installing them from start+computer+install software …) hal-devel, cmake, gperf, nasm…
then it finally finished configuring.

after i got a make error:
make[2]: *** [tif_ojpeg.o] Error 1
make[2]: Leaving directory /home/rickseh/XBMC_9.04_Babylon-linux-osx-win32/xbmc/lib/cximage-6.0/tiff' make[1]: *** [tiff/tiff.a] Error 2 make[1]: Leaving directory /home/rickseh/XBMC_9.04_Babylon-linux-osx-win32/xbmc/lib/cximage-6.0’
make: *** [imagelib] Error 2

i downed libtiff-devel, openjpeg, and libopenjpeg-devel
still got a make error, tried make clean && make
still a make error, installed libzypp-devel
looking for Cximage because its in the make error.
compiling…, reading around its amsn<— that needs to be installed…

Sure you don’t mean yasm which is the re-written NASM assembler?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 10 days 13:44, 2 users, load average: 0.61, 0.43, 0.22
GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14

still a **** make error

In file included from tif_ojpeg.c:35:
/usr/include/jpeglib.h:1096:55: error: jpegint.h: No such file or directory
i installed tk-devel and tcl-devel and some others

In file included from tif_ojpeg.c:35:
/usr/include/jpeglib.h:1096:55: error: jpegint.h: No such file or directory
tif_ojpeg.c: In function ‘OJPEGPreDecode’:
tif_ojpeg.c:1414: error: dereferencing pointer to incomplete type
tif_ojpeg.c:1424: error: dereferencing pointer to incomplete type
tif_ojpeg.c:1425: error: dereferencing pointer to incomplete type
tif_ojpeg.c:1426: error: dereferencing pointer to incomplete type
tif_ojpeg.c:1428: error: ‘DSTATE_INHEADER’ undeclared (first use in this function)
tif_ojpeg.c:1428: error: (Each undeclared identifier is reported only once
tif_ojpeg.c:1428: error: for each function it appears in.)
tif_ojpeg.c:1508: error: dereferencing pointer to incomplete type
make[2]: *** [tif_ojpeg.o] Error 1
make[2]: Leaving directory /home/rickseh/download/XBMC_9.04_Babylon-linux-osx-win32/xbmc/lib/cximage-6.0/tiff' make[1]: *** [tiff/tiff.a] Error 2 make[1]: Leaving directory /home/rickseh/download/XBMC_9.04_Babylon-linux-osx-win32/xbmc/lib/cximage-6.0’
make: *** [imagelib] Error 2

— heh yeah amsn is a im client, it says nasm, screw yasm… downing jpegint-devel

thats about it. it compiled ok, all you gotta do is enable the upnp server, set sources, and right click the video and music folders and scan add to library.