function keys doesn't works

Most function keys don’t works anymore.
F6 (volume off), F7 (volume down), F8 (volume up), F2 and F3 (brightness) don’t have any effect.
All these regulation can still be done using mouse.

It looks as if you use a Graphical Desktop Environment. But you fail to explain which one (KDE. Gnome, …).

Sorry, I forgot.
My DE is KDE, not clear which version. May be useful: I update regularly, Dolphin version is 21.12.3.

Info Center tells you all. Copy and paste here:

Operating System: openSUSE Tumbleweed 20220802
KDE Plasma Version: 5.25.3
KDE Frameworks Version: 5.96.0
Qt Version: 5.15.5
Kernel Version: 5.18.12-1-default (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 5600X 6-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX 550 / 550 Series
Manufacturer: Micro-Star International Co., Ltd.
Product Name: MS-7C56
System Version: 2.0

Thanks, very useful.

Operating System: openSUSE Leap 15.4
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.14.21-150400.22-default (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i7-6500U CPU @ 2.50GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 520

By the way this problem affect other distributions (openMandriva Lx 4.3) using KDE. May be a KDE problem?

Is the user using the same home directory for the different distributions? Then it could be something in her/his KDE config files.

Try creating a fresh user and see if that user has the same problem.

I am not so sure. Have a look at https://docs.kde.org/stable5/en/khelpcenter/fundamentals/shortcuts.html

Under what circumstances (older OS-version, different OS, …) did the function keys work as expected?

Which function keys do still work “as before”?

Is this a Laptop and the F-keys in question are labelled (“brightness up”, “brightness down”, …)?

Regards

susejunky

No. openSuse and openMandriva are installed in different partitions.

Try creating a fresh user and see if that user has the same problem.
I have three users:

  1. the “main” user created during installation I use almost always
  2. user created after installation, I use rarely
  3. user created today
    In none of them functions keys works.

It is logical that the different systems are installed on different partitions, but the question was (in short) if they use the same partition for /home.

Well, that in fact answers bot the question about the shared home and the test with a fresh user.

It seems I have no shortcuts set. I press “reset to default” button but nothing change. Not sure but I think functions keys software is part of kernel.

Alt+F2 started krunner in previous versions of KDE. Nothing happens with the current version.

I use frequently functions keys, mainly for volume and they worked till one or two days ago.

Which function keys do still work “as before”?
I would say none of them. At least “fn” key seems having no effect.
As an example using VLC to listen music F11 / Fast Forward key should have two functions:
F11 -> toggle VLC windows to whole screen <-> mid size window
Fast Forward -> jump to the next song in folder
Normally I can chose between two functions pressing “fn” key. Now “fn” key has no effect, pressing it or not F11 always change VLC window dimension.

Is this a Laptop and the F-keys in question are labelled (“brightness up”, “brightness down”, …)?

Yes. As an example F7 (volume down) key has a loudspeaker and minus sign “-” .

Is there a chance that just your “Fn”-key gave up (hardware defect) or does it still work with some “Fx”-keys (e.g. to change brightness)?

Regards

susejunky

After my last message I had the same doubt. I checked all my os and in none fn key worked.
Then I try to take apart the key “cap” and this probably unlock the key (that was locked in “pressed” position) now it works normally. And I hope it will keep on working.
Thanks to all for hints.

Plasma System Settings > Shortcuts > Krunner > Defaults wouldn’t work. Logged out from KDE Plasma, moved ./.config/kglobalshortcutsrc, logged in again. That restored defaults.