Fullscreen not working in HTML5 Videos

Hi.
I’m having an issue playing HTML5 videos (testing it on YouTube). When I press the fullscreen button nothing happens (except Firefox is running slower and I have to restart it to work properly).
I got the libav libraries installed as mentioned here https://en.opensuse.org/SDB:Firefox_MP4/H.264_Video_Support

I already tried:

  • refreshing Firefox
  • removing Firefox config directory from home
  • disabling all of the addons
  • forcing hardware acceleration
  • disabling hardware acceleration
  • disabling webm (I read that it would force h264)

None of the above helped. What else can I do?

Note the link you referenced says add Packman or VLC repositories - it does not say add both.

There was a time when adding both would create a problem - and I am not certain if that is still the case - as for over a decade I have never added VLC repository.

Can you confirm that you added only one of those repositories and not both?

Only Packman repo is added.

Have you force installed all the packman versions - the opensuse versions do not work and yast does not force update

sudo zypper in

it will show what it could not install

sudo zypper in -f ‘cut and paste the files names here one line at a time’ and say yes to install them

that should fix the non-packman files in opensuse

I does no such thing…
Anyway, I tried Switching system packages to Packman in Yast and that did not help either.

This is strange.

I assume if you download the HTML videos (using something like youtube-dl from Packman) that the downloaded videos play with no problem on your PC.

I note guidance here for HTML-5 videos not playing in Firefox. The one suggestion they mention that I believe you may not have tried is

  • You need to check the media prefs that do not have the default value.
  • If the media.windows-media-foundation.enabled is set to false, you need to set it to true and restart.

Out of curiosity, to you see anything unusual (that might give us a hint as to the issue) if you visit this youtube page with firefox:

https://www.youtube.com/html5

I copied prefs.js from other Laptop which works just fine (pretty similiar laptop with Leap 15.1 too) and that did not help. There is no such setting media.windows-media-foundation.enabled
I will check the youtube-dl in few moments. **EDIT: **Did work.

This page is not working for me since few weeks, it show me that my browser is up to date and is supported.
But I checked that page on web archive and that one works fine and shows that everything is good.

This should work for you.

My current assessment is one of the things that you note you attempted, was not done completely (as this should work - it works for me and others). In particular I am curious about this “removing Firefox config directory from home” … did you really get everything?

If you create a new user, and launch firefox from that new user account, does that new user have same issue?

The idea behind that test is to try and localize where the problem may be. If both new user and current user have the issue, that confirms it is not likely a user level issue, but more system wide.

I got it.

If you create a new user, and launch firefox from that new user account, does that new user have same issue?

I thought about doing it yesterday. And new user had no such problem.

For a reason I don’t know I’ve set up Window setting Fullscreen -> Force No for Firefox and that was the issue.

Congratulations on sorting this. Thankyou for sharing your solution.