Fullscreen mode and autocomplete makes black blink

Hi everybody.

I have a weird problem in my Aspire One D150 with an Intel 945 GME, and in my HP DV5 with an Intel GM45. When i put a window like Firefox in full screen mode (F11), and try to get into a menu, or an auto-complete option or trying to access a URL in the history of the address bar, results in a black blink that its very annoying, because it happens all the time.

This problem appears in the most GTK Apps that i run in full screen mode. QT Works perfect. If the composite its off, works perfect in both.

This happens in KDE 4.3.5 and KDE 4.4.1, so I have no clue about this. I want my composite on, and make that the GTK Apps work as well as the QT ones.

I already tried a lot of things before make this post without success. :’(

So, thanks in advance for any help to this matter :smiley:

Cheers.

Hello alexbariv,

You’re already giving us a lot of information.
But it would help if you could tell us which version of openSUSE you have.

After some searching I found a bug report with a similar problem.
I don’t know if it works but you can try the steps of comment #2.

  1. open ~/.kde/share/config/kwinrc in an editor
  2. go to section [Compositing]
  3. Add following line:
    UnredirectFullscreen=false
  4. Save file and restart kwin (alt+f2 and kwin --replace)
    If this doesn’t work have a look at comment #17](177495 – (unredirect-flicker) Fullscreen windows unusable due to heavy flickering).
    It says that you need to open the file ~/.kde4/share/config/kwinrc.

Best of luck!:wink:

Hahaha, true, i give a bunch of information, except the most important… And of course, I’m on 11.2 with the KDE 4.4 repo.

I added UnredirectFullscreen=false to the kwinrc as you pointed and problem solved :smiley:

Many thanks for your help :smiley:

Cheers and keep in touch :wink: