Fullscreen games & OpenSuSE 11.3

I just realized recently that with just about any game I am running with Wine in OpenSuSE 11.3, I can no longer switch to different workspaces and back to the one containing the game without having the game suddenly ‘shrink’ to Window size. Any reason why this is happening? It’s only as of OpenSuSE 11.3 that this issue came about.

I am running Gnome default. Zypper dup’d OpenSuSE 11.3 from 11.2.

Is there any way to get around this/put it back to the way it was?

Much love, and much thanks :slight_smile: <3

Well then. After digging around some more, I stumbled across a posting in Fedora forum. A fellow has the exact same issue as me. It turns out it’s’ a Gnome bug that was introduced with 2.30. KDE does not suffer from this.

To those that were interested/wondering.

So either wait for a patch, or upgrade to newer Gnome (OR downgrade/use SuSE 11.2)

Wow. 198 views and not a single comments? Am I seriously the only person getting this problem in OpenSuSE 11.3/Gnome?

Would be nice if someone tossed in their two cents…

Hi,

If you have documentation on the bug, then please file in a bug report within GNOME and you might see it updated soon.
If no one files a bug report on it, the longer it takes for it to be solved. Every bug is worth reporting, I’m pretty sure GNOME people will appreciate it a lot.

https://bugzilla.gnome.org/

Maybe that’s a good place to start with :slight_smile:

I hope this is the ultimate answer you might be looking for.

Thank you kindly :slight_smile:

Though from what the fellow in the Fedora forum said, it seems there already is a bug report that was submitted. I don’t want to create a duplicate. However, I will attempt this either way just in case.

I am not aware of this bug… but if you can please place the link for Fedora I will take a look :slight_smile:

Lets say I became suddenly interested on this bug which I can’t replicate either on Fedora nor on openSUSE 11.3…

I’ve tested on ATI hardware some commercial games in full screen:

  • Unreal Tournament 2004
  • Neverwinter Nights
  • Quake 4
  • Doom 3

And all of them work properly, except NWN which has some weird screen tearing, but I suppose that’s SDL related and not exactly to anything. Running updated 11.3 system with GNOME from openSUSE except for this two changes:

notification-daemon > replaced by notify-osd
nautils > replaced by nautilus elementary

The Driver is proprietary ATI. I can’t replicate the bug in any of the games mentioned above.