Full screen Flash EXTREMELY slow with Intel, and I fixed it by sheer luck...

That is because it is a workaround, not a solution. The solution has to come via the graphics driver developers.

hwinfo --framebuffer gives:

02: None 00.0: 11001 VESA Framebuffer
[Created at bios.459]
Unique ID: rdCR.5dHCGM_Ucd6
Hardware Class: framebuffer
Model: “Intel(r)Q33/Q35/G33 Graphics Controller”
Vendor: “Intel Corporation”
Device: “Intel(r)Q33/Q35/G33 Graphics Controller”
SubVendor: “Intel(r)Q33/Q35/G33 Graphics Chip Accelerated VGA BIOS”
SubDevice:
Revision: “Hardware Version 0.0”
Memory Size: 7 MB + 960 kB
Memory Range: 0xe0000000-0xe07effff (rw)
Mode 0x0360: 960x600 (+960), 8 bits
Mode 0x0361: 960x600 (+1920), 16 bits
Mode 0x0362: 960x600 (+3840), 24 bits
Mode 0x0363: 1440x900 (+1472), 8 bits
Mode 0x0364: 1440x900 (+2880), 16 bits
Mode 0x0365: 1440x900 (+5760), 24 bits
Mode 0x0366: 1680x1050 (+1728), 8 bits
Mode 0x0367: 1680x1050 (+3392), 16 bits
Mode 0x0368: 1680x1050 (+6720), 24 bits
Mode 0x033c: 1920x1440 (+1920), 8 bits
Mode 0x034d: 1920x1440 (+3840), 16 bits
Mode 0x033a: 1600x1200 (+1600), 8 bits
Mode 0x034b: 1600x1200 (+3200), 16 bits
Mode 0x035a: 1600x1200 (+6400), 24 bits
Mode 0x0307: 1280x1024 (+1280), 8 bits
Mode 0x031a: 1280x1024 (+2560), 16 bits
Mode 0x031b: 1280x1024 (+5120), 24 bits
Mode 0x0305: 1024x768 (+1024), 8 bits
Mode 0x0317: 1024x768 (+2048), 16 bits
Mode 0x0318: 1024x768 (+4096), 24 bits
Mode 0x0312: 640x480 (+2560), 24 bits
Mode 0x0314: 800x600 (+1600), 16 bits
Mode 0x0315: 800x600 (+3200), 24 bits
Mode 0x0301: 640x480 (+640), 8 bits
Mode 0x0303: 800x600 (+832), 8 bits
Mode 0x0311: 640x480 (+1280), 16 bits
Config Status: cfg=no, avail=yes, need=no, active=unknown

and menu.lst:

Modified by YaST2. Last modification on Sex Fev 3 06:43:22 BRT 2012

THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader

For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,0)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title Desktop – openSUSE 12.1 - 3.1.9-1.4
root (hd0,0)
kernel /boot/vmlinuz-3.1.9-1.4-desktop root=/dev/disk/by-id/ata-WDC_WD3200AAJS-00L7A0_WD-WCAV2J273366-part1 resume=/dev/disk/by-id/ata-WDC_WD3200AAJS-00L7A0_WD-WCAV2J273366-part5 splash=silent quiet showopts
initrd /boot/initrd-3.1.9-1.4-desktop

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 12.1 - 3.1.9-1.4
root (hd0,0)
kernel /boot/vmlinuz-3.1.9-1.4-desktop root=/dev/disk/by-id/ata-WDC_WD3200AAJS-00L7A0_WD-WCAV2J273366-part1 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x317
initrd /boot/initrd-3.1.9-1.4-desktop

caf4926, i firstly just wanted to say that this problem seems to happen with the whole computer (being a bit slow), and not only with “full screen flash”. just wanted tto share the info, maybe then you could better understand the problem.
as i said, i don’t experience the problem anymore. something else i observed: always when i turned on the computer, at the first time all my desktop icons wouldn’t be shown, and a kind of “scrollbar” was on the right side of the screen (in vertical direction). i had to finish my session, and log in again, then i could see my icons, and the scrollbar would be gone.

i think there’s no problem anymore, although we don’t have a splashscreen now (this is rather a detail…).you are right, it doesn’t bother, and i also don’t worry about the splash.
i am new with openSUSE, and i am finding the distro very nice, and the forum is really helpful. many thanks.

ah sorry, haven’t finished the sentence: after doing how is said in this thread, this problem is gone as well.

If you are interested, it’s the part vga=*** that makes possible the splash. It’s missing from the default boot, but present in your Failsafe entry. Look

###Don’t change this comment - YaST2 identifier: Original name: linux###
title Desktop – openSUSE 12.1 - 3.1.9-1.4
root (hd0,0)
kernel /boot/vmlinuz-3.1.9-1.4-desktop root=/dev/disk/by-id/ata-WDC_WD3200AAJS-00L7A0_WD-WCAV2J273366-part1 resume=/dev/disk/by-id/ata-WDC_WD3200AAJS-00L7A0_WD-WCAV2J273366-part5 splash=silent quiet showopts
initrd /boot/initrd-3.1.9-1.4-desktop

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 12.1 - 3.1.9-1.4
root (hd0,0)
kernel /boot/vmlinuz-3.1.9-1.4-desktop root=/dev/disk/by-id/ata-WDC_WD3200AAJS-00L7A0_WD-WCAV2J273366-part1 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe ** vga=0x317**
initrd /boot/initrd-3.1.9-1.4-desktop

You could write that down and try typing it at the boot menu. (If you reboot, and as soon as the timer is ticking on the default boot, just start typing the vga= on your keyboard. It will display in the the boot arguments, it stops the timer too, so once you finish typing, hit enter)
You could also try vga=0x318, it’s the 24bit version from the info you posted.
If it works, we can add it permanently.

However, I’m wondering how the entry was removed? Because I know some intel users have found that removing the vga= from the argument improves the flash performance etc… so perhaps you are actually one of these and better off without it.

Hi again.
It’s changed in the boot options.I don’t use the system in english, so i don’t know the exact name of it. It could be “boot loader” (rocket icon…). I think it has the same effect as editing the grub text file?
Anyway, there you can see the entries of the boot menu. I selected the desktop entry, and in the options i can change for example its name, or how many seconds it will last until the entry is automatically chosen…as well as the VGA Mode. At the moment mine is set as “not specified”.
http://img820.imageshack.us/img820/1570/imagem2arm.png
Well, i tried the 24 bit version (editing in boot loader), and i was back to the same problem with flash (made a test on youtube)
Yes, i am actually one of these users. So for now i should leave it this way? (i mean, no VGA Mode). Or it does make a sense, to test all the VGA Mode options, until i find one which doesn’t make the computer slow? I mean, do you believe it’s possible? If not, it’s okay how it is. As i said, no splash screen doesn’t bother me, but it’s nice knowing more about a problem.

Regards

So for now i should leave it this way? (i mean, no VGA Mode).
Yes
It’s OK to have no splash, some users prefer it

I don’t however understand why this no vga option works

I recalled reading long time ago in the results of a google probably from some other forum, that the vga parameter interfered with KMS. That turned out to be “only in some situations”, and one can’t believe everything stated on the internet. For myself, it has never solved anything but for some it surely has. :slight_smile:

For what its worth, in this somewhat dated thread, I note some Fedora and Arch Linux users have stumbled across a different solution with Intel Graphics, when Full Screen is choppy and slow.

The reference threads are:

The symptom was with an Intel graphic hardware/driver, when playing video fullscreen in totem, the video is stuttering and choppy, but is fine when played in a window.

and the ‘solution’ adopted in those threads was to place the following two lines in /etc/environment


CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True

No guarantees here. Just some information that I thought that I would pass along that may or may not help.


CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True

Doesn’t help.
openSuSE 11.4, Linux 3.19 x64 on Sandybridge.

Index of /repositories/home:/ilya_41:/branches:/openSUSE:/12.1:/Update/openSUSE_11.4/x86_64
Tried to backport Mesa and xorg from 12.1: nothing changes.

Well I have one with a slow flash on full screen.
I use smplayer to play flash and helps, though
Not entirely perfect because I can’t play the so called flash embedded videos on sites.
Hopefully someone will teach me to make it work in smplayer.

I’ve added DirectFB to my build-repo and dup’ped from it. After that, I don’t see any unresponsiveness from full-screen HD flash-video controls, but the overall performance of the playback is poor anyway. So the difference is small but it’s there.

Setting the vga mode to none still works MUCH better.
P.S.: By the way, 11.4 installation with 3.19 kernel from my repo only (without upgrading xorg, mesa, etc.) seems to brake hibernation, and 2.6.x kernel seems to be unsupported a bit by relatively fresh hardware.

Just thought I’d mention that window performance is much smoother by not defining vga mode at boot for my old laptop using VIA’s chrome9 chipset. Flash performance is still poor due to the lack of drivers (and the dodgy hardware, of course!), but windows are drawn much faster and the whole system feels more responsive. Also, since 11.4, when opening a new window I used to see garbage before the window contents where created / updated, but this no more. And I think boot up time has been reduced by a few seconds. I really don’t care that much about the boot splash when I get this sort of improvement on performance. Thanks!

this thread is dated, i just posted something similar but this is my exact issue, most of you seem to have had luck with this.
streaming videos online it becomes choppy and i have zero control on full screen unless i use the window switcher.
can somebody give me a walkthrough with the vga= issue?
i’m a fairly basic linux user and terminal is not always my strong suit.

thanks:)

Opensuse 12.2 KDE


<00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
01:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
02:00.0 Network controller: Atheros Communications Inc. AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)>

To see if this trick works in your case you can use YaST. From the KDE Menu, or wherever, open up YaST and go to the Boot options. Under the Boot options, change the Grub Boot Loader options, and choose “Unspecified” for “VGA mode”.

This is a very old thread, so I’m not sure if it will still apply in your case. Doesn’t hurt to try. By doing this, you will lose the fancy boot screen.

bummer, when i opened the boot options it appears VGA was already unspecified.
any further ideas?

ive played with the hardware acceleration in flash and no luck with that either.

You’re likely suffering from a different issue than what was brought up in this thread. One thing I would try, in your case, is to see if you get better performance with Flash under Google Chrome. Yes, Google Chrome, not Chromium. It has PAPPI Flash bundled with it at version 11.6 (as of this post.) See if you notice any difference.

You can also try “Text Mode” instead of “Unspecified” which might have the same beneficial effect.

Google Chrome worked! or so it seems after watching a few minutes of video, controls were working just fine:)
I’ll watch something more this evening to make sure. Can i safely remove Chromium? i have the disk space i just like to keep things to what i need.

I will try Text Mode if i find any issues with Chrome. Am i running any risk changing the VGA settings? or just potentially out of shape screen?

Thank you! very simple fix. i had done many things along the way i wish i could backtrack on lol. but nothing seems affected.

Chromium can be safely uninstalled, as it does not affect Google Chrome on the same system. Chromium is the “open-source” browser, without some features bundled with Google Chrome, such as PAPPI Flash, PDF reader, and some things unique to Google’s proprietary build. There are “philosophical” reasons why some people don’t use Google Chrome, but it’s up to each individual’s needs and preferences.

The “VGA setting” set to “Unspecified” or “Text Mode” will only affect the boot splash screen and colors. “Text Mode” will basically be a black-and-white text when you boot the system. The reason this “trick” works for many people is because of a bug with “VGA mode” and the Intel drivers using KMS. Thus, setting it to “Text Mode” or “Unspecified” fixes the issue. You won’t ruin anything in your case, except for a “pretty” boot splash screen.

Am 18.03.2013 21:36, schrieb flansuse:
> Chromium is the “open-source” browser, without some
> features bundled with Google Chrome, such as PAPPI Flash
It has this: look at the package chromium-pepper-flash
I use it and it shows me flash version 11.6 in chromium.


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.1 | GTX 650 Ti
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.1 | HD 3000
eCAFE 800: oS 12.2 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10