Fujitsu Amilo A 7620 laptop freezes.

Installing Ubuntu 9.04 to a Fujitsu Amilo A 7620 laptop, freezes during writing to disk at about 20-30% of the installation proccess.
I tested all the possible commands found in forums at boot installation without success.
Same thing happens with suse linux 11.1.
Finally I installed suse 11.1 through network installation without any problem.
When I try to check the suse installation dvd media through the properly installed program, the whole system freezes and needs restart (power off and power on).
The freezing happens when request a heavy operation from the dvd (NEC ND5100A) and not when I do a dir to the dvd.
Any idea please?:confused:

Does ubuntu boot and run from the cd/dvd?
If it does, before installing anything, check that you can access the internet, the drives on the computer, etc.

Since you say you did a net install of 11.1, I take it that all is working, but it’s only a problem when you access the dvd drive?
If this is the only problem, it could be a problem with either the dvd drive or the media.

First sorry for the delay.
Unfortunately, the reference dvd player operates normally in windows environment.
I have checked the media before installation and found the right but when I check it through the installed suse, the laptop blocks.
So, it haw to be something else.
A dvd firmware update would it be a solution?

What DVD are you trying to load? It could be a problem with permissions or not having a codec pack installed if its a movie or something.

Installation of OpenSuse freezes as described in several threads on a Siemens Fujitsu Amilo A 7620 at 20-30%.
But installation with network as source seams to solve this problem, if you connect your PC via LAN directly to your router.
DHCP on your router must be enabled!
I tried OpenSuse 11.1 and 11.4 and it worked fine. I´m optimistic for 12.1, but I didn´t try it.

  1. Download DVD and burn image
  2. Connect your Amilo directly to your router
  3. Boot from DVD and Check Installation Media. If media is OK then choose
  4. F4 Source: HTTP
    Directory: /distribution/11.4/repo/oss/ (distribution dependend)
    Network Config: DHCP
  5. Installation
    If your router is configured correctly the installation will now start. Follow the further instructions.
    The only disadvantage is the longer installation time.
    Have fun