fstab messes up Grub?

Hello All

This is no longer a problem, merely a request for education. I am a long time Suse user, recently my ancient computer had a major melt-down. So I had to buy a new one. I did my research and only bought hardware that other users were able to install Suse 11.1 successfully.

Something unique about the new computer is the SATA hard drive. I have always been an PATA user. One thing that I noticed is that SATA drives are mounted by id, but are also listed under /dev/sda.

Another thing that is new to me is the GRUB boot loader. I have always been a LILO user, loving it for its simplicity. Yet have noticed it is not supported with Suse, so during the installation I switched to GRUB.

I installed openSUSE 11.1 with no problems. Managed to install the graphics drivers. Fixed the IPv6 problem. Did a kernel update, changed the default kernel for grub. Rebooted successfully many times since. Everything was running really smooth. Very happy with my new computer. 

So I have some other computers running in the house with NFS servers. After the installation I manually added them to fstab. While editing fstab, I tried to experiment and see if I could mount my sata partitions using the device "/dev/sdaN". It seemed to work, so I re-edited fstab to the familiar /dev/sdaN. 

I rebooted, but then when GRUB would normally show up I would get a blinking cursor and nothing more. I tried fixing it with the repair utilities on the openSUSE disc. Nothing worked there.

So far I have had many problems trying to fix the system and things seem to be getting worse, but that is besides the point. Can someone enlighten me on the mounting procedure for sata drives at boot. Tell me how would editing fstab mess up grub, it seems to me that they would be totally seperate applications. 


Are you saying it has only one internal drive?

Well it should of worked fine if that was the case. Grub doesn’t care for /dev/whatever that only understands hdx,y

If you never got to a grub screen this implies it couldn’t find the 1st part of grub.

Now you can google if you want it all proper as I’m not going to go into all the stages. here’s one I found for example Details of GRUB on the PC

1st part grub is usually installed into the mbr of the first disk booting, this from my limited understanding isn’t much more than a pointer saying not here go here. So after that it gets to the next bit finally to grub with menu.1st. Now having tested this if the first bit is found you’ll get an error code. I tested it in my vmware by renaming my grub folder.

You seem to be describing it couldn’t find the 1st stage which doesn’t make much sense. I wouldn’t of thought this was possible with just one drive, now I don’t have a partition marked as bootable so not sure this affects it either.

With just a single drive I’m not sure this should of happened, so I can only presume you have more than one. Then you are either choosing some kind of autoselect for boot order or have swapped them in bios.

Without seeing the specifics, it’s hard to say what the precise problem is. Having said that, you really don’t want to be mounting partitions by “name” anymore. Problems began with this after introduction of SATA, because BIOS’s did not consistently or reliably report the order of the combined PATA and SATA disks. Even with the maturing of SATA - where typically all the drives are under a single controller - BIOS’s may not report the sequence correctly. And of course, with multiple SATA ports each interchangeable by the user, this can exacerbate the sequence reporting problem. All this affects partitions by “name” as the name is dictated by the sequence. Consequently, distros have switched to one of the other methods for the default: by hardware-ID (SuSE), by label (Fedora), and by UUID (Ubuntu). But all support all of the methods allowed by the kernel (which maintains a cross-reference between them all). In YaST Partitioner you can specify the mount method for each partition and YaST will write the fstab entry accordingly. YaST Boot Loader module will also now use ID rather than name in grub’s device.map and menu.lst control files, again for greater reliability.

So . . . now when you boot, are you getting the grub menu and then blinking cursor after selecting openSUSE to boot? Or are you not even getting the grub menu? Have you tried booting from the DVD and selecting “boot from hard disk”?

FeatherMonkey and mingus725

FeatherMonkey thanks for playing with your VMware instalation. I never got any error message from Grub, nor did I get a menu from Grub. Your post educated me that the MBR would have been corrupted on my hardrive. 

mingus725 I appreciate your explaination of how SATA drives are treated. I will not access hardrives by name anymore. Your explaination, has lead me to believe that I got the drive mapping wrong, or my PATA cdroms were reported in a different order. Either way everything was mapped wrong and the MBR was corrupted in some miss-directed write operation. 

I feel better that the mistake was mine, and not a bug. Learning is a lot easier than coding. I am happy to report that I am writing this post from my newly installed and operating openSuse 11.1 installations. Thanks for the help, I will not make that mistake again.

Take Care

Glad it all worked out for you. If you run into another problem, don’t hesitate to ask - that’s why we’re here.