fstab ignores (?) login information?

I have spent 5 hours trying to figure this out, but I can’t.
Obviously, I am not seen some detail and I need another pair of eyes here.

I am trying to mount two network locations (NAS) using fstab:

//   /home/Wizard/Multimedia cifs vers=3,rw,uid=1000,credentials=/home/Wizard/.smblogin,iocharset=utf8 0 0
//       /home/Wizard/Public     cifs vers=3,rw,uid=1000,credentials=/home/Wizard/.smblogin,iocharset=utf8 0 0

Everytime I boot, or use “mount -a”, I am getting a prompt to enter “root@//” password.
However, Public folder is mounted everytime. This one, has rw access to “everyone”, while Multimedia has rw access to certain group, where “MyUser” is a member.

To figure out if the .smblogin file was the issue, I tried to mount it manually, and it works:

sudo mount -t cifs // /home/Wizard/Multimedia -o credentials=/home/Wizard/.smblogin

Also, on another machine, with Mint 18.3 Sylvia, I am using the exact same lines in fstab and same smblogin file.

Any suggestions?

No user name in the samba db, so I would guess it defaults to root user, have a read here;


Thank you for the swift response.
Unfortunately it didn’t help. I am getting the same error.
In the document it says than it is needed even if you want to mount with the “mount” command, which in my case is working.

So as your user, can you connect via smbclient (-A for the authentication file), add some debug via -d2 else check the smb.conf on the other system and compare to the openSUSE /etc/samba/smb.conf.

I am able to connect using smbclient, however these warnings I am not sure if they affecting the mounting process.

Wizard@my-pc:~> smbclient \\\\\\Multimedia -A /home/Wizard/.smblogin -d2
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Can't find include file /etc/samba/dhcp.conf
Unable to initialize messaging context
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Can't find include file /etc/samba/dhcp.conf
added interface vmnet8 ip= bcast= netmask=
added interface eno1 ip= bcast= netmask=
added interface vmnet1 ip= bcast= netmask=
Cannot do GSE to an IP address
Try "help" to get a list of possible commands.
smb: \>

Can you increase the debug to -d4 and see if vers=3 needs setting?