fstab enry for Western Digital My Book Home Edition


After re-installing openSUSE 11.3/KDE 4.4. the following entry appeared in /etc/fstab which fails to mount my WDH1CS10000E external hard drive.

/dev/disk/by-id/usb-WD_My_Book_57442D574341553430313936383130-0:0-part1 ‘/media/My Book’ ntfs-3g users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0

Any idea what’s wrong?

A simple entry in /etc/fstab like

**/dev/sdb1 ‘/media/My Book’ **

is also not working

Thanks in advance.


Unusual for a USB HD to get added to fstab
All mine are plug and play, no fstab entry.

Try # it out

You say it fails, but you not not show us the error message. With the first entry above in your /etc/fstab do (as root)

mount /media/'My Book'

and see what is said.

Then, please put those computer in/output line between CODE tags and not bold (Posting in Code Tags - A Guide.

Then, starting from Carl’s post above, is this device to be on the system allways from boot to shutdown? When not, you by accident left it connected during installation and thus was seen by the install as a permanent disk and thus an fstab entry was made.

The fact that you apparently mount it in a directory in /media hints that it is in fact a “come and go” device, which shoudl be handled by HAL. When that is true, you should remove the entry from /etc/fstab because HAL does NOT handle plug in devices when mentioned in the fstab.

In any case, it should not be using /dev/sdb1!
Partitions have UUIDS and disk-IDs on USB disks too.

Good remark, I wonder why the install did not do this correct.

On 2011-01-09 17:06, hcvv wrote:

> Good remark, I wonder why the install did not do this correct.

The install used ID. It is the user who tried sdb1. :slight_smile:

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Minas Tirith))

Sorry, my fault, should have gone to the top the reread.

Try the following entry instead of the first one your put forth. Don’t try putting the ‘around’ the name and use an underscore instead to get it to work. You should just use the defaults setting for NTFS partitions as well.

/dev/disk/by-id/usb-WD_My_Book_57442D574341553430313936383130-0:0-part1 /media/My_Book ntfs-3g defaults 0 0

You must create the folder /media/My_Book for this to work. I might also suggest you use something else like /Windows or /Software or /Mediafiles (You must be root to create these folder names) and stop using the media folder as it is part of the auto-mounting setup used by openSUSE.

I might also add that I owned one of these external USB drives and even booted openSUSE from it, but it has been nothing but trouble. First off, the hard drive went bad, while in warranty and I had to send it off for repair. Now, even as I can convince it to work by cycling its power, it often just seems to lock up in never never land or just shuts off even as the PC is still on. I ended up ditching the drive into my closet where it may rot or be given to Good Will, but it will never be used with openSUSE again. I would start looking for a replacement today.

Thank You,


Thanks for those tons of help. Am a bit confused now.

A few things.

Yes, the HD was connected during the installation of openSUSE 11.3. But it used to be connected during various other installations before . No problems then.

I do have a directory /media/My Book.

manually mounting the HD as root via #mount /dev/sdb1 'media/MY Book# does work.

yes, i had a dual boot installation (Win7/openSuSE 11.3) on that machine before.

I will disable the fstab entry for the HD and try again.



I have a WD Elements usb HD always connected, even at install.
It never gets added to fstab
I never add it to fstab
It has a volume label ; ELEMENTS
It always mounts in /media at boot and the folder ELEMENTS is then present


Other usb devices (flash/pen drives) mount on plugin
I give each of my devices a unique Label Eg; backupusb
And they mount in /media as such


Deleting the entry in the /etc/fstab did the job. Should’ve thought of that myself in the first place.

Thanks for all your help.


Deleting the entry in the /etc/fstab did the job. Should’ve thought of that myself in the first place.

Didn’t I say that in the first place?


my fstab reads:

LABEL=Vantec /vantec/F ntfs-3g users,users,gid=users,umask=0002 0 0

Is a Vantec enclosure with a 3.5’ WD hard drive, connected to the eSATA port.
openSUSE 12.3 freshly installed.

Everything is working OK.


On 2013-09-24 14:56, davidbrunstein wrote:
> Everything is working OK.

Please, notice that this is a thread from 2011, long ago, and was solved.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)