FSCK Ext4 Problem

So I have my 12.2 64bit running perfectly for months, but after a power failure, the home partition (/dev/sda3 in my case) has errors and it hangs at booting.
so after booting as root in system recovery option (or how ever that is called) I tried to run fsck, which did not allow me because the partition was mounted. I tried umount on the partition, but it says is busy so it can not be unmounted.

How can I unmount the partition so it can be checked and fixed? I tried so many things, even running fsck from a live cd, tried a forced unmounting, and no solution.

I already checked fstab and its good.

Any help would be greatly appreciated.

If you were using a live CD why would the partition be mounted?

Have you tried GParted? You can use it to check partitions in the Partition Manager

When I used the live cd the partition was not mounted, but fsck ran for about half a second and came back saying that it did not find anything.

If a drive is not clean, fsck is run automatically at boot. So I guess, it is clean now.

You could try to force fsck to run by specifying the “-f” parameter. But since it seems it already has run, I don’t think it will fix your boot problems.

Could you please explain what you mean with “the home partition (/dev/sda3 in my case) has errors and it hangs at booting.” ?
Is this still the case?
What error messages do you get?

I am assuming is the home partition (for the normal user), since that had happened before but I was able to fix it. What happens is that at booting the computer hangs when trying to mount /dev/sda3, which is my home partition. I might be wrong, since after 30 seconds, a new screen appears and sends me to the terminal and ask my root password.

Let me ask you something else, just to make sure I am addressing the correct problem:

Is there some sort of log that records all the processes at boot so I can definetely identify what is messing my pc?

So after 30 seconds the mount times out. Well, when you are asked for the root password then enter your root password. You would enter “emergency mode” then.
/dev/sda3 shouldn’t be mounted then since the mount timed out, so you could issue the fsck. If there’s an error message, please post it.

Regarding logs, there are few:

  • Run “dmesg”
  • Run “journalctl -b”
  • look into /var/log/messages
    At least one of them should contain something interesting.
    (the first two only show the log of the current boot, so do that in emergency mode when the boot failed)

When the partition with issue is not mounted (/dev/sda3) when you were asked to login as root then
after root is login you can run

fsck /dev/sda3