fsck error after cloning openSUSE

After cloning an openSUSE 11.1 installation using Clonezilla (basically did dd and partimage on the hard drive) I had a couple of problems which running the repair system on the DVD fixed all but one. The problems that was fixed include no swap partition on the cloned machines, the root partition trying to be mounted as /data2 instead of /, no GRUB, and it did not update the MBR. The one problem that it did not fix is with the /home partition, when I try and boot a cloned machine I get this error from e2fsck:

The superblock could not be read or does not describe a correct ext2 filesystem. If the fevice is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock
e2fsck -b 8193 <device>

When I tried the command that it suggested I got a “bad magic number” and it reprinted that error.

When I ran fsck -y on that same partition this is what it had to say:

/dev/sda7: clean, 2190/3022848 files, 249069/1278864 blocks

Anyone know what to do in this case?

I have tried to recover it and no matter which superblocks that I try it keeps saying they are bad, so I did dd on the good machine put the image on a portable hard drive and that wasn’t even able to mount. What is the command to make a new ext3 partition since is seems fixing this one is out of the question?