Frozen at the lightbulb screen..

Hello , I’m a Linux noob but have been running opensuse TW (KDE) with no issues for around a year now. Today I read about a software called “deepin music player” and wanted to install it. When I tried installing it via Yast’s “Install/Remove Software” it said there was a conflict and one of the “resolutions” was to change the “Mesa” vendor from “PAC-MAN” to “opensuse”, so I selected that. A bunch of changes took place and the install finished.

Now after restarting my PC, it loads upto the screen that has “geeko” in a lightbulb and then hangs. I hit Ctrl+alt+F1 and it says my opensuse TW ver: 20170622 - kernel (tty1). Now I have no clue what to do? I was thinking maybe I should do a “zypper” update to try and fix this?

Any help is appreciated, I’d like to get back to using my PC the way it was before. If you need more information from me, please ask. Thanks in advance.

In my case,the solution was here

why are you still on kernel are you using update and/or apper instead of zypper dup?

I deleted the folders ~/.cache/ and /var/lib/sddm/.cache/ but that didn’t help :(. Situation still the same.

@ndc33: I’m on an older kernel b’cos that was the last time I did an update. Everything was working well, so I never bothered updating TW. That’s why I’m thinking maybe it’s high time I did an update now?

Before trying other things, first run

su -c 'zypper dup'

to upgrade to the latest released snapshot

I did: su -c ‘zypper dup’ . It took a long while but completed eventually.

Now I have an nvidia graphics card so I have to do every time I upgrade.

I have nvidia driver files for ver: 381.22 and 375.66 in my “Downloads” folder. So I did:

su -
echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf && mkinitrd && reboot

and after restart:

su -
sh /home/user/Downloads/

Here I’m getting this error: (with both versions of drivers)
[FONT=.SFUIText]An error occurred while “building kernel modules”[/FONT]
[FONT=.SFUIText]See /var/log/nvidia-installer.log for details [/FONT]

I looked at the .log file, but I can’t make any sense of it and I don’t know how to copy it to a USB drive. I also looked at the nvidia driver page and it seems that the latest driver version is 390.25. again don’t Know how to copy it to my PC or whether it will help.

Forgot to mention, for this command

$ rm -f /usr/lib*/*

These files don’t exist, so there’s nothing to remove.


$ zypper in --force libglvnd0

just says that the package libglvnd0 doesn’t exist!

It’s prudent to always download the latest driver before a zypper dup.

The drivers you already had definitely won’t work.

There are some direct download links at
You could try:
wget <url>

I’m on an older kernel b’cos that was the last time I did an update. Everything was working well, so I never bothered updating TW.

If you don’t want to do a zypper dup at least once a month,
then you would probably be a happy Leap user.
With Leap you can just do zypper patch.

Yes; I noted libglvnd* doesn’t exist, on the wiki’s discussion page.
Apparently, it’s not required anymore – because I can install without it.

Great! That did it.

Thank you to everyone who replied. This is why I choose opensuse over other Distros. Best community ever!

@ravas: updating every month was the plan, but I started slacking. Going forward I’ll update it more often for sure.