Frostwire

I downloaded Frostwire to my openSUSE Tumbleweed. When I tried to fire it up, it stated that I didn’t have Java installed. No problem. I installed Java and tried to fire it up again and get the following message

eddie@linux-p6fs:~> frostwire
HOSTNAME IS linux-p6fs.site
Starting FrostWire...
Java exec found in PATH. Verifying...
OOPS, you don't seem to have a valid JRE. FrostWire works best with Sun JRE available at http://www.java.com [java = openjdk]
You need to upgrade to JRE 1.7.x or newer from http://www.java.com
ls: cannot access /usr/lib/j*: No such file or directory
OOPS, unable to locate java exec in  /usr/lib/  hierarchy
You need to upgrade to JRE 1.7.x or newer from http://www.java.com
Java exec found in  /usr/java/jre1.8.0_25/bin/
Suitable java version found  [/usr/java/jre1.8.0_25/bin/java = 1.8.0_25]
Configuring environment...
Loading FrostWire:
Error: Unable to access jarfile frostwire.jar

/usr/java/jre1.8.0_25/bin/
******************************************************************
Something went wrong with FrostWire.
Maybe you're using the wrong version of Java?
(FrostWire is tested against and works best with with Sun's JRE, Java 1.7+)
The version of Java in your PATH is:
openjdk version "1.8.0_40"
OpenJDK Runtime Environment (build 1.8.0_40-b12)
OpenJDK 64-Bit Server VM (build 25.40-b16, mixed mode)

eddie@linux-p6fs:~> 

What am I doing wrong?

What java did you install from where?

There is a Tunbleweed forum here. That is the place where the Tumbleweed users gather.

Had the same issue here. Cured by removing all instances of Java, then installing

java-1_7_0-openjdk

All good after that. So tried re-installing jre 1.8 and same again. So looks like an incomatibility problem between the two. Had to revert again for it to run.