FromMAFF to Web Page complete

I often have to download newspaper articles to my files using Firefox.

To date, the standard default in Save As has always been Web Page, Complete. However, recently, this switched to Web Archive, MAFF, although I never asked this to be the case. Although I can use the drop down menu to Save As Web Page, Complete, there has to be a way of setting this as the default, but I cannot find a way of doing this.

Can anybody help?

Many thanks!

Can you at least tell which version of openSUSE you use. It is also a good idea to mention which desktop when there is the slightest possibility that you are using one. And in this case the version of Firefox might also be of interest.

I have openSUSE 13.1 with Firefox 29.0 on KDE. When I try to use “Save as …” on this very page, the default in the Filter is: Webpage, complete. Other possibilities given are: Webpage, HTML only, Text and All. I see no MAFF there (whatever it might mean).

Maybe a better description of what you do, see and experience is needed.

Hi Henk,

I am using Suse 12.3 and Firefox 28.

If I try to Save As - for example the Suse home page - the default option presented on the drop down menu will be Web Archive, MAFF. However, the drop down will allow Web Page, Complete (which is what I want as default).

I am on Gnome.

Actually, just upgraded to Firefox 29, but my default option is still the same.

I’m on 12.3 FF 29 also and I don’t see a MFF option. Maybe it comes from addon???

That could be. I see an addon Mozilla Archive Format, but for me the mnemonix is then MAF, not MAFF.

Just to point out that I haven’t modified my version of Suse in any way at all or added new functions: I have simply used the automatic update.

On the drop down menu, the options given (in order) are: Web Archive, MAFF; Web Archive, HTML; Web Page, complete; Web Page, HTML only; Text Files: All Files.

I don’t need Web Archive - whatever that is - but simply need to save as Web Page, complete.

Is there really no way of setting that as default?

I have the same list as you ecept for the first item *the one you do not want).

WE did not say that it an openSYSE change or addon, but a FF addon.

You couuld try to creat a new user to see if the problem persists. Then yiou know it is in the personal setttings or not.

Please check your FF addins. We are not suggesting things and you doing no investigation at all.

There is an addon for Maff (Extra > Addons and then MAFF in the top right search filed willbring you there. I do not have it installed.

It was indeed a FF Add on, which I have now disabled.

Never enabled it in the first place, though!

Thanks for your help.

I do not believe in magic though :slight_smile: