Fresh Slow Roll or fresh TW install . . . wha happen, mon?

Folks:

I downloaded the “10/3” iso from the Slowroll distro site and cloned it to usb drive a week or so back. Yesterday I ran a fresh install of it.

On the download site there was something like, “don’t do online update because that will bring in TW packages” . . . before I ran the install the first time I tried disconnecting the ethernet, but then the installer couldn’t format the internet connection? I started the installer again, remembering in the installer was usually a question about, “online upgrade?” When I got there I picked “no.”

Install went through fine. Historically for the grub multi-boot process I found it better to “shut down” rather than restart, but the installer said, “We are restarting now” picking no, did nothing, so I had to pick “OK” . . . it restarted into new install. Then I shut it down. On cold boot the system flashed a “We are updating your system” message across the screen, didn’t open a console . . . it took a fair amount of time to move the cig bar across the screen. And it restarted itself. I checked the zypper ref output after that and nothing about “slowroll” was mentioned. Checked YaSt repos . . . just shows “tumbleweed” . . . . I just added the Packman stuff, but didn’t run a zypper dup on the system yet.

Is this a fast TW install now, or it’s TW . . . but it will slowly upgrade???

~> sudo zypper ref
[sudo] password for root: 
Repository 'Packman Essentials Repository' is up to date.                       
Repository 'Packman Repository' is up to date.                                  
Retrieving repository 'openSUSE-Tumbleweed-Non-Oss' metadata .............[done]
Building repository 'openSUSE-Tumbleweed-Non-Oss' cache ..................[done]
Repository 'Open H.264 Codec (openSUSE Tumbleweed)' is up to date.              
Retrieving repository 'openSUSE-Tumbleweed-Oss' metadata .................[done]
Building repository 'openSUSE-Tumbleweed-Oss' cache ......................[done]
Repository 'openSUSE-Tumbleweed-Update' is up to date.                          
All repositories have been refreshed.

Did you check and replace the repos after installation?
https://en.opensuse.org/openSUSE:Slowroll

You need to replace the Tumbleweed repos with Slowroll repos and do a zypper dup.
A cat /etc/os-release afterwards shows you what you are using…

1 Like

@hui

Ah . . . I saw those instructions but I thought that was for migrating from an existing TW or Leap install . . . . Did not understand that downloading the “Sloroll” iso would also need to change the repos???

OK, so I see the commands listed to rm the repos . . . but can those new updated repos be “bulk” copied and pasted into something/somewhere in the console??

Or, it’s a copy paste in YaSt to edit the slowroll http locations one line at a time kind of a thing???

1 Like

It is no Slowroll ISO but a simple “old” Tumbleweed ISO

If you use the standard terminal under Plasma, you can copy the complete code section, insert it into the terminal and hit enter twice…

1 Like

Additionally the very first post in the Slowroll part of the forum already mentions and explain that:

Looked around a bit, didn’t see any “Slowroll part of the forum” for exclusive “Slow Roll” conversations . . . .

But, looks like it went through OK . . . seems a bit “cumbersome” . . . install TW and then change the repos to roll back 800 packages . . . but, OK . . . got it done.

Thanks for the pointers on it.

# cat /etc/os-release
NAME="openSUSE Tumbleweed-Slowroll"
# VERSION="20231003"
ID="opensuse-tumbleweed"
ID_LIKE="opensuse suse"
VERSION_ID="20231003"
PRETTY_NAME="openSUSE Tumbleweed-Slowroll"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20231003"
BUG_REPORT_URL="https://bugzilla.opensuse.org"
SUPPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org"
DOCUMENTATION_URL="https://en.opensuse.org/openSUSE:Slowroll"
LOGO="distributor-logo-Tumbleweed"

1 Like

I have the same issue as the OP. The instructions on that project page do not specify that user has to alter repos, only that Leap and Tumbleweed users do.

I’ll try to edit the page but want to be perfectly clear. Are users supposed to replace all the repositories using the code section under the line below? And this needs to happen before they run ‘zypper dup’ or add more repos?

To use in Leap or an older Tumbleweed, replace repositories

rm /etc/zypp/repos.d/*
   zypper ar --refresh http://cdn.opensuse.org/repositories/openSUSE:/ALP:/Experimental:/Slowroll/base/repo/oss/ base-oss
   zypper ar --refresh http://cdn.opensuse.org/repositories/openSUSE:/ALP:/Experimental:/Slowroll/base/repo/non-oss/ base-non-oss
   zypper ar --refresh -p 80 http://cdn.opensuse.org/repositories/openSUSE:/ALP:/Experimental:/Slowroll/standard/ update
   zypper ar --refresh --disable http://cdn.opensuse.org/repositories/openSUSE:/ALP:/Experimental:/Slowroll/base/repo/src-oss/ base-src-oss
   zypper ar --refresh http://codecs.opensuse.org/openh264/openSUSE_Tumbleweed/ h264
   zypper ar --refresh -p 70 http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Slowroll/Essentials/ packman

I adjusted the page accordingly.

3 Likes

Yes. Copy/paste those commands in the console (I believe as root), hit return . . . it runs through all of the lines, except for the last, Packman, line . . . hit return again to finish the last line.

Then run zypper dup as you would for a normal TW install . . . that will regress a bunch of packages to what will be the SlowRoll iteration . . . it’s “TW,” albeit “Slow” version . . . .

1 Like

HI.
Couldn’t you change those lines to https repositories instead of http? In the end I’m using the Spanish page which already has them in https… :sweat_smile: :sweat_smile:
I am aware that I am a security freak :thinking:

Why not doing it yourself? :roll_eyes:
But you also noticed that the spanish page uses no longer applicable URLs pointing to ALP experimental?

And it does not add any security as the standard for almost all distributions is to use http repo URLs as there are other ways to prove secure packages and downloads…
What advantage do you expect from https for a pure download mirror?

1 Like

Looks like there are again a few repos to change, as they have been updated since I made this post . . … 4 have changed, don’t know if it’s easier to just bulk run them as before . . . or just do them one at a time in YaSt . . . . I’m a few days away from Slo Roll day . . . .

There are changes going on at both packman and openSUSE build service repositories hold off for a few days until the dust settles

1 Like

HI.
I said it was my idea. After each installation I change all the repositories from http to https except one which regularly gives an error if changed. I’m new to Linux and rely on what I do in Windows which is much more vulnerable. :smiley: :smiley:

Not specific about this subject, but trying to apply your Windows knowledge to a Linux environment is in general not a good idea. The somewhat exaggerated expression is “When going to Linux, forget everything you learned about Windows”.

2 Likes

@malcolmlewis

OK, thanks for the hint on it . . . looks like Slo Roll day might be Friday . . . is that enough time for the cyber-dust to settle out on the repo changes??

@non_space looks like it’s been fixed now for Packman https://lists.links2linux.de/pipermail/packman/2023-November/017650.html

1 Like

I’ve done 2 TW and 2 SR dups since your previous thread post, smoothly, and uneventfully. Standard repos don’t seem to be part of the ongoing infrastructure issues.

1 Like

Cool. There have been so many posts lately I’ve lost track of them . . . .

Changing gears a bit, hitting some quiz questions on my Leap 15.6 install that seems to be “repo” related. Based upon advice to move the kernel away from “devel,” I did that, uname -r showing “6.4” kernel, but still getting these questions. I think I unchecked the “OBS Backports” repo . . . ?

Loading repository data...
Warning: Repository 'update-backports (15.6)' metadata expired since 2023-09-29 02:08:32 PDT.
Warning: Repository 'update-non-oss (15.6)' metadata expired since 2023-09-21 05:47:58 PDT.
Warning: Repository 'Update repository of openSUSE Backports' metadata expired since 2023-09-29 02:08:32 PDT.

    Warning: Repository metadata expired: Check if 'autorefresh' is turned on
    (zypper lr), otherwise manualy refresh the repository (zypper ref). If this
    does not solve the issue, it could be that you are using a broken mirror or
    the server has actually discontinued to support the repository.

Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...

Problem: problem with the installed kernel-macros-6.6.1-lp155.5.1.g4f13ec5.noarch
 Solution 1: install kernel-macros-6.4.0-150600.1.4.noarch from vendor SUSE LLC <https://www.suse.com/>
  replacing kernel-macros-6.6.1-lp155.5.1.g4f13ec5.noarch from vendor obs://build.opensuse.org/Kernel
 Solution 2: keep obsolete kernel-macros-6.6.1-lp155.5.1.g4f13ec5.noarch

Choose from above solutions by number or cancel [1/2/c/d/?] (c):

Solution 1

1 Like