Fresh OpenSUSE Leap installation: boot problem

Because pictures communicate better than words:
Trying to get my first linux OS running here. I’m using hardware that I believe to be compatible. I used most of the default options during installation and accepted the suggested options, the only thing I did that was not default was I opted to not create a user account. I learned of my mistake when I was only able to login using root as username and my root password so I added an user account using YaST. Besides that I haven’t done anything with this computer.

The problem happens inconsistently. Maybe about 1/3 of the time, it boots and launches without an issue. About the other 2/3 of the time, the system hangs on the icon as shown in the photo above, and then after some time the jarbled terminal looking thing appears. I seem to be able to type in commands into it.

I really have no idea what’s going wrong and am feeling totally clueless as to how to diagnose and use linux on my computer. Please help! :slight_smile:

So exactly what hardware??

The pictures indicated corrupted fonts or text. I assume you don’t see this corruption when it boots correctly???

So possible failing drive may cause this.

Try hitting the e key when the grub menu appears, finding and deleting “quiet” and “splash=silent” before proceeding with boot. If it doesn’t make any apparent difference, try hitting the e key again on next try and append “plymouth.enable=0” on that same line, with or without the same deletions. Do as gogalthorp asked if these things don’t help.

The computer is a few months old. It has a Samsung SSD 860, 2700x AMD CPU, AMD Radeon RX 580 GPU and an ASUS prime 370x-pro with G-Skill Flare X series RAM.

It appeared that removing splash=silent and quiet fixed the problem. It wasn’t lagging on the icon screen and then displaying the blurred writing, but after the ninth system reboot it occurred again. I went to add that extra line as you said, but I’m rather unsure as when I’ve pressed e, the splash=silent and quiet is still there. I thought since I deleted it, it wouldn’t be there?

Using the e key at the boot screen is for testing. If a solution via that test proves successful, it needs to be made permanent by editing the corresponding line(s) in the configuration file /etc/default/grub and then regenerating the grub menu using the grub2-mkconfig command

grub2-mkconfig -o /boot/grub2/grub.cfg

Or, easier for GUI users, Yast=>Boot Loader, Kernel Parameters (middle tab), add it to the Optional Kernel Command Line Parameter to make it permanent. OK & Save/Exit will do the rest.

Thanks everybody it’s appeared that the issue is now fixed. For my curiosity, is anyone able to describe why changing those lines fixed my booting problem?

I wasn’t able to work out how to save the edited **/etc/default/grub **file, so thank you Fraser for showing me how to do it with YaST because that was easy to do.

I wasn’t sure if it was necessary but I ran
grub2-mkconfig -o /boot/grub2/grub.cfg
in the terminal just to be safe.
I rebooted the computer about 30 times just to make sure it was working fine. During one of those times, as it was turning itself off to then turn itself back on again, the computer froze and became unresponsive. I took this photo of it:

I noticed that it failed unmounting /var. Upon further rebooting I noticed it always says this. I’m not sure if this is significance at all, should I be concerned? I’m not sure why it froze one time out of thirty, is this somewhat normal at all?

Hey all,

sorry to bother you all again but I’m experiencing a similar problem as before. Here’s an image:

It appears that I’m able to type into a terminal, but I cannot read the writing as its garbled.

The strangest thing is I haven’t messed around with any settings or done much of anything that could be causing this problem. I can’t seem to login anymore as this error is popping up each time.

I am dual booting this with Windows 10 which is running off the same SSD. Could that be causing this problem?

Any help is appreciated.

Can anyone help me with this error? If not I’m going to have to erase OpenSUSE from my computer and move onto another distribution and hope for a better outcome, because currently I cannot boot into OpenSUSE, nor can I boot into a snapshot and I don’t have the knowledge to begin to diagnose and fix this problem by myself.

I opened your last image, but it’s too blurry to be of any use. Maybe if you used instead it could turn out better.

Image is plured and last line where error happened is not fully visible. Maybe just tell us that last line

You are welcome. As for the grub file, you would edit it as root and save as root.

I wasn’t sure if it was necessary but I ran

grub2-mkconfig -o /boot/grub2/grub.cfg

in the terminal just to be safe.

Not unusual, probably not necessary, but some of us often do that, too, just to make sure. I will do it on occasion.

At one point, something was missed, and for awhile the Yast module would not do that, so we had to run that, then run the CLI Grub install until that was fixed.

Sorry about the poor image before. Hope these help.

I figure I could try erasing and reinstalling OpenSUSE from the live USB if I don’t have another option in trying to fix this problem.

I didn’t see that your reply gogalthorp. I can’t read the writing either as it’s distorted.

This image here is the close up of the error:

I’ve been thinking about this off and on for several hours. The more I think, the more I suspect hardware failure. The video cable and RAM would be simple to test with another cable or if more than one stick is installed taking out one RAM stick at a time or swapping RAM slots. Software could be tested by using a live media of some other distro, like Knoppix or Mageia.

I have wondered if it’s hardware related. If it’s anything, I suspect it’s the CPU as I had some inconsistent stability results when running stress tests with it on Windows 10.

I don’t have a video cable on hand unfortunately. I did read of someone having a similar issue with Arch Linux, which they fixed by plugging their monitor into the DP port instead of the HDMI port.

Would running a memtest be sufficient to test the RAM?

I’ll test using a live media of another distro. I should mention that I’ve had no such errors with Windows 10.

Not necessarily, only tell if bad, not guarantee good, and it takes a lot longer than slot swapping. Both needed.

I should mention that I’ve had no such errors with Windows 10.
You don’t see that video mode used by Windows.

A while ago I ran pretty much into the same error myself.
In my case it turned out that the network service caused the display manager to time out during boot.
Mobile computers get Network Manager installed by default, while my desktop pc was installed with the wicked network service activated.
As I don’t have special needs for my networking, I made my life easier and switched my service to Network Manager.
The easiest way to do that is to fire up YAST, open the Network settings module and under the global options, I switched from wicked to Network Manager.
That was it for me and since than I have never had this issue again.

Hope that works for you as well


I used to be able to boot up where I could access YAST. For some unknown reason though, now I cannot boot into OpenSUSE at all, so I cannot try out your suggestion unfortunately. Did you have difficulties booting into OpenSUSE?


Good to know that Windows doesn’t use this video mode. I presume that Knoppix/Mageia also doesn’t, which is why you suggested it?

If it is hardware related, is just the RAM or the video the potential culprits, or could something else like the CPU also be causing this error? When you say the “video cable”, are you talking about the core that plugs from the monitor into the GPU, or the cord that plugs the GPU into the mobo? I think I’m going to have to buy a whatever cord I need to test it as I don’t have a spare.

Thanks for the help guys, I hope I can resolve this problem and get on with using OpenSUSE! :slight_smile:

As I mentioned in a previous post, I had 3 laptops, each dual-boot Windows 10 / Leap 15. After updates, the Grub failed on each every time I chose Linux. After tearing my few remaining hairs out and re-installing Windows 10 on each system, I finally installed linux on a USB harddrive and changed bios to boot from it by default. The first 5-6 times all went well, but then grub failed again. This time, thankfully, all I had to do was unplug the disk drive to return to a functional windows system. I miss linux.